HDU1021

Fibonacci Again
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 61756 Accepted Submission(s): 28836

Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output
Print the word “yes” if 3 divide evenly into F(n).

Print the word “no” if not.

Sample Input
0
1
2
3
4
5

Sample Output
no
no
yes
no
no
no

Author
Leojay

Recommend
JGShining | We have carefully selected several similar problems for you: 1061 1108 1071 1049 1032


**题目分析:
简单的数论题,f(n)要能整除3,公式可改写为F(n) = (F(n-1) + F(n-2))mod 3,计算一下发现第二个后面的以4为基数开始循环**

#include<cstdio>
int main()
{
    int n;
    while (scanf("%d",&n)!=EOF)
    {
        if ((n - 2) % 4 != 0)
            printf("no\n");
        else
            printf("yes\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值