1059 Prime Factors (25point(s))质因子分解

Given any positive integer NNN, you are supposed to find all of its prime factors, and write them in the format NNN = p1k1×p2k2×⋯×pmkm{p_1}^{k_1}\times {p_2}^{k_2} \times \cdots \times {p_m}^{k_m}p​1​​​k​1​​​​×p​2​​​k​2​​​​×⋯×p​m​​​k​m​​​​.

Input Specification:

Each input file contains one test case which gives a positive integer NNN in the range of long int.

Output Specification:

Factor NNN in the format NNN = p1p_1p​1​​^k1k_1k​1​​*p2p_2p​2​​^k2k_2k​2​​**pmp_mp​m​​^kmk_mk​m​​, where pip_ip​i​​'s are prime factors of NNN in increasing order, and the exponent kik_ik​i​​ is the number of pip_ip​i​​ -- hence when there is only one pip_ip​i​​, kik_ik​i​​ is 1 and must NOT be printed out.

Sample Input:

97532468

 

Sample Output:

97532468=2^2*11*17*101*1291

 思路:把素数表先存起来, 因为是是int以内 , sqrt(max int) 在比10的五次方小, 素数表开到10五次方就行了, 再用n值和素数表的数逐个比对。

#include <iostream>
#include <math.h>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
using namespace std;
int isPrime(int x){
	if(x == 1) return 0;
	int sqr = (int)sqrt(1.0 * x);
	for(int i = 2; i <= sqr; i++){
		if(x % i == 0) return 0;
	}
	return 1;
}
const int maxn = 100010;
int prime[maxn], pnum = 0;
void Find_Prime(){
	for(int i = 2; i < maxn; i++){
		if(isPrime(i)){
			prime[pnum++] = i;
		}
	}
}
struct factor{
	int x, cnt;
};
int main(int argc, char** argv) {
	factor fac[10];
	Find_Prime();
	int n, num = 0;
	cin >> n;
	if(n == 1) cout << "1=1";
	else{
		cout << n << "=";
		int sqr = (int)sqrt(1.0 * n);
		for(int i = 0; i < pnum && prime[i] <= sqr; i++){
			if(n % prime[i] == 0){
				fac[num].x = prime[i];
				fac[num].cnt = 0;
				while(n % prime[i] == 0){
					fac[num].cnt++;
					n /= prime[i];
				}
				num++;
			}
			if(n == 1) break;
		}
		if(n != 1){
			fac[num].x = n;
			fac[num++].cnt = 1;
		}
		cout << fac[0].x;
		if(fac[0].cnt > 1) cout << "^" << fac[0].cnt;
		for(int i = 1; i < num; i++){
			cout << "*" << fac[i].x;
			if(fac[i].cnt > 1) cout << "^" << fac[i].cnt;
		}
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值