1059 Prime Factors (25)(25 point(s))

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1^k1* p2^k2 *…*pm^km.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1^k1 * p2^k2 *…*pm^km, where pi's are prime factors of N in increasing order, and the exponent ki is the number of pi -- hence when there is only one pi, ki is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291
#include <iostream>
#include<cmath>
using namespace std;
int n;
struct factor{
	int x, cnt;
}p[110];
bool isPrime(int n){
	if(n<=1)return false;
	int k=sqrt(1.0*n);
	for(int i=2; i<=k; i++){
		if(n%i==0){
			return false;
		}
	}
	return true;
}
int num=0;
void find_Prime(){
	int k=sqrt(1.0*n);
	for(int i=2; i<=k; i++){
		if(isPrime(i)==true&&n%i==0){
			p[num].x=i;
			p[num].cnt=0;
			num++;
		}
	}
}
int main() {
    scanf("%d", &n);
    printf("%d=", n);
    if(n==1)printf("1");
    else{
    	find_Prime();
    for(int i=0; i<num; i++){
    	int j=p[i].x;
    	while(1){
    		if(n%j!=0)break;
    		n/=j;
    		p[i].cnt++;
		}
		if(n==1)break;
	}
	if(n!=1){
		p[num].x=n;
		p[num].cnt++;
	}
	for(int i=0; i<=num; i++){
		if(p[i].cnt!=0){
			if(i==0)printf("%d", p[i].x);
			else printf("*%d", p[i].x);
			if(p[i].cnt>1)printf("^%d",p[i].cnt);
		}
	}
	}
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值