1096 Consecutive Factors (20point(s))

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<2​31​​).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]*factor[2]*...*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

 

Sample Output:

3
5*6*7

思路:n不会被除自己以外大于根号n的数整除 ,所以遍历2 到 根号n。

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <vector>
#include <algorithm>
using namespace std;

int main(int argc, char** argv) {
	long long  n;
	cin >> n;
	int maxlen = 0, maxi;
	long long sqr = (long long)sqrt(1.0 * n);
	for(int i = 2; i <= sqr; i++) {
		long long temp = i, j = i;//temp保存当前的乘积
		while(n % temp == 0) {//除得尽
			j++;
			temp = temp * j;
		}
		if(maxlen < j - i) {
			maxlen = j - i;
			maxi = i;
		}

	}
	if(maxlen == 0) {//如果最长长度没改变则这个数为本身
		cout << 1 << endl;
		cout << n << endl;
	} else {
		cout << maxlen << endl;
		cout << maxi;
		for(int i = maxi + 1; i < maxlen + maxi; i++) {
			cout << "*" << i;
		}
		cout << endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值