ACM-数论之Big Number——hdu1018

***************************************转载请注明出处http://blog.csdn.net/lttree******************************************

 

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24823    Accepted Submission(s): 11267


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
  
  
2 10 20
 

Sample Output
  
  
7 19
 

Source
 


题目:http://acm.hdu.edu.cn/showproblem.php?pid=1018

 

题目内容:求n!的位数。

比如10!=3628800 是7位数。

 

我一直以为找规律,找啊找。。。

最后发现是一个 斯特林公式。。。

对数学的崇拜又加深了~\(≧▽≦)/~

 


斯特林公式(Stirling's approximation)是一条用来取n的阶乘的近似值的数学公式。
一般来说,当n很大的时候,n阶乘的计算量十分大,所以斯特林公式十分好用,
而且,即使在n很小的时候,斯特林公式的取值已经十分准确。
更精确为

或者

————以上均取自 百度百科

 

 

<span style="font-size:18px;">************************************** 
***************************************** 
*        Author:Tree                    * 
*From :http://blog.csdn.net/lttree      * 
* Title : Big Number                    * 
*Source: hdu 1018                       * 
* Hint : 斯特林公式                     * 
***************************************** 
****************************************/  

#include <stdio.h>
#include <math.h>

#define Pi acos(-1.0)
#define e 2.71828182

int main()
{
	int t,n;
	double m;
	scanf("%d",&t);
	while( t-- )
	{
		scanf("%d",&n);
		// 斯特林公式
		m = (double)n*log10(n*1.0/e)+0.5*log10(2.0*n*Pi);
		printf("%d\n",int(m)+1);
	}
	return 0;
}</span>


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值