hdu 4268 Alice and Bob

Alice and Bob's game never ends. Today, they introduce a new game. In this game, both of them have N different rectangular cards respectively. Alice wants to use his cards to cover Bob's. The card A can cover the card B if the height of A is not smaller than B and the width of A is not smaller than B. As the best programmer, you are asked to compute the maximal number of Bob's cards that Alice can cover. 
Please pay attention that each card can be used only once and the cards cannot be rotated. 
 
Input
The first line of the input is a number T (T <= 40) which means the number of test cases. 
For each case, the first line is a number N which means the number of cards that Alice and Bob have respectively. Each of the following N (N <= 100,000) lines contains two integers h (h <= 1,000,000,000) and w (w <= 1,000,000,000) which means the height and width of Alice's card, then the following N lines means that of Bob's. 
 
Output
For each test case, output an answer using one line which contains just one number. 
 
Sample Input
2
2
1 2
3 4
2 3
4 5
3
2 3
5 7
6 8
4 1
2 5
3 4 


Sample Output
1


分析:

贪心思想,需要利用到set。



今天学习了下set,STL真强大。将Alice的card标记为id = 0,Bob的card标记为1。将所


有的纸片按照h,w的升序排序,按照id的降序排序,也就是在相同情况下将Bob的纸片放


前面。然后将Bob的纸片的w插入set,贪心选取Alice比Bob的纸片w大一点的来覆盖,然


后删掉被覆盖的纸片。

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <set>
using namespace std;

const int MAXN = 200100;
typedef multiset<int> SET;
typedef multiset<int> :: iterator P;
struct node
{
    int h,w,id;
    bool operator < (const node &b) const
    {
        if (h!=b.h) return h<b.h;
        if (w!=b.w) return w<b.w;
        return id>b.id;   //排序过程
    }
};
node a[MAXN];
SET d;
int main()
{
    int n,t,i,ans;
    scanf("%d",&t);
    while (t--)
    {
        scanf("%d",&n);
        for (i=1;i<=n*2;i++)
        {
            scanf("%d%d",&a[i].h,&a[i].w);
            if (i>n) a[i].id=1;
            else a[i].id=0;
        }
        sort(a+1,a+n*2+1);
        d.clear();
        ans=0;
        for (i=1;i<=n*2;i++)
        {
            if (a[i].id) d.insert(a[i].w);
            else
            if (! d.empty()&&*d.begin()<=a[i].w)
            {
                P p=d.upper_bound(a[i].w);//取上限
                ans++;
                p--;  //变成小于a[i].w的最大值
                d.erase(p);
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值