HDU 4268 Alice and Bob(贪心)


  

Alice and Bob

                                                               Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
Alice and Bob's game never ends. Today, they introduce a new game. In this game, both of them have N different rectangular cards respectively. Alice wants to use his cards to cover Bob's. The card A can cover the card B if the height of A is not smaller than B and the width of A is not smaller than B. As the best programmer, you are asked to compute the maximal number of Bob's cards that Alice can cover.
Please pay attention that each card can be used only once and the cards cannot be rotated.
 

Input
The first line of the input is a number T (T <= 40) which means the number of test cases. 
For each case, the first line is a number N which means the number of cards that Alice and Bob have respectively. Each of the following N (N <= 100,000) lines contains two integers h (h <= 1,000,000,000) and w (w <= 1,000,000,000) which means the height and width of Alice's card, then the following N lines means that of Bob's.
 

Output
For each test case, output an answer using one line which contains just one number.
 

Sample Input
  
  
2
2
2 3
1 4
4 5
2 3
3 2 3
5 7 6 8 4 1
2 5 3 4
 

Sample Output
  
  
1
2
 

Source
 

Recommend
liuyiding
题目大意:

Alice和Bob手中都有N张排,每张牌都有自己的长H和宽W,当Alice牌的长和宽都大于等于Bob时,就说Alice的牌能够覆盖Bob的牌,问Alice最多能覆盖多少张Bob的牌,每张牌只能用一次。

解题思路:

先对Alice和Bob的牌按照H(or W)从大到小排序,然后从Alice牌中挑出比Bob【i】.H大的牌放进multiset , 再在set里面找出第一个比Bob【i】.W大的,然后释放set里面的这个元素且个数加一,再进行下一个Bob的元素。。。


代码:

#include<iostream>
#include<cstdio>
#include<set>
#include<algorithm>

using namespace std;

const int maxN=110000;
int n;

struct node{
    int h,w;
    node(int h0=0,int w0=0){
        h=h0,w=w0;
    }
    friend bool operator <(node a,node b){
        if(a.w!=b.w) return a.w<b.w;
        else return a.h<b.h;
    }
}Alice[maxN],Bob[maxN];

bool cmp(node a,node b){
    if(a.h!=b.h) return a.h>b.h;
    else return a.w>b.w;
}

void solve(){
    multiset <node> mul;
    sort(Alice,Alice+n,cmp);
    sort(Bob,Bob+n,cmp);
    int r=0,cnt=0;
    for(int i=0;i<n;i++){
        while(r<n&&Alice[r].h>=Bob[i].h) mul.insert(Alice[r++]);
        multiset<node>::iterator it=mul.lower_bound(Bob[i]);
        if(it!=mul.end()){
            mul.erase(it);
            cnt++;
        }
    }
    cout<<cnt<<endl;
}

int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        for(int i=0;i<n;i++) scanf("%d%d",&Alice[i].h,&Alice[i].w);
        for(int i=0;i<n;i++) scanf("%d%d",&Bob[i].h,&Bob[i].w);
        solve();
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值