【poj2965】The Pilots Brothers' refrigerator

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4

Source

Northeastern Europe 2004, Western Subregion

【解析】

这题好啊~

让我学会了新的方法【歪门邪道】¥-¥

这道题就是给你一个只有'+'、'-'的4*4矩阵,最后变成全部是'-'的一个矩阵

每次点击开关都会把开关所在的整行整列改变

输出点击开关次数和点击的开关

其实~最多就按16次,按一个2次是没有区别的,按3次不就是按1次嘛

所以——不用慌

解法很神奇(膜拜大佬%%%)

如果开关是关的,那么就把开关所在的行和列动1遍

最后统计每个开关动的次数,如果是奇数,那么就输出

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char ss[5];
int a[5][5],s[5][5];
int cx[21],cy[21];
int main()
{
	memset(a,-1,sizeof(a));
	memset(s,0,sizeof(s));
	for(int i=1;i<=4;i++)
	{
		scanf("%s",ss+1);
		for(int j=1;j<=4;j++)
		{
			if(ss[j]=='+') a[i][j]=0;
			else a[i][j]=1;
		}
	}
	for(int i=1;i<=4;i++)
	{
		for(int j=1;j<=4;j++)
		{
			if(a[i][j]==0)
			{
				for(int k=1;k<=4;k++)
				{
					s[i][k]++;
					s[k][j]++;
				}
				s[i][j]--;//s[i][j]重复加了一次 
			}
		}
	}
	int ans=0;
	for(int i=1;i<=4;i++)
	{
		for(int j=1;j<=4;j++)
		{
			if( (s[i][j]%2)==1)
			{
				ans++;
				cx[ans]=i;cy[ans]=j;
			}
		}
	}
	printf("%d\n",ans);
	for(int i=1;i<=ans;i++) printf("%d %d\n",cx[i],cy[i]);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值