Trees on the level HDU - 1622

问题:

Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics. 

This problem involves building and traversing binary trees. 
Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes. 

In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1. 

For example, a level order traversal of the tree 

 
is: 5, 4, 8, 11, 13, 4, 7, 2, 1. 

In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L's and R's where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once. 
 

Input

The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses. 

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file. 
 

Output

For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete'' should be printed

Sample Input

(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()

Sample Output

5 4 8 11 13 4 7 2 1
not complete

题意:

(a,b):路径b的节点值是a。(a,):a是根节点。()数据输入结束。L表示向左插入,R表示向右插入。

判断是否构成一颗树,如果是则按照层次顺序显示节点,如果不是则输出not complete。

思路:

没有更节点,或有多个更节点,节点的路径重复,或者缺少节点就不能构成构成树。

代码:

#define N 260
#include<set>
#include<string>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int t,fff,sum;
set<string>h;
struct node
{
    int a,al;
    char ss[N];
} s[N];
bool cmp(node x,node y)
{
    if(x.al==y.al)return strcmp(x.ss,y.ss)<0;
    else return x.al<y.al;
}
void dfs(int a,string as)
{
    int i=a;//每一个子树根节点都比孩子节点的路径长度大一,且孩子节点的路径在根节点的路径上+L或R
    while(i<t)//在层次顺序中孩子节点在根节点之后
    {
        if(as.length()+1<strlen(s[i].ss))break;//不能找到孩子节点
        
        //寻找孩子节点
        string ac=as+'L';
        if(ac.compare(s[i].ss)==0)
        {
            sum++;
            dfs(i+1,ac);
        }
        ac=as+'R';
        if(ac.compare(s[i].ss)==0)
        {
            sum++;
            dfs(i+1,ac);
            break;
        }
        i++;
    }
}
int main()
{
    char k[N];
    while(~scanf("%s",k))
    {
        h.clear();
        t=0;
        fff=0;
        int flag=0;
        int gen=-0x3f3f3f3f;
        if(strlen(k)==2)
        {
            printf("not complete\n");
            continue;
        }
        else do//这个题数据预处理还是比较麻烦的
            {
                int l=strlen(k);
                if(l==2)
                    break;
                int num=0;
                int i=1,f=0,bl=0;
                char b[N];
                for(int j=0; j<N; j++)b[j]='\0';
                while(k[i]<='9'&&k[i]>='0')//提取根节点的值
                {
                    num=num*10+k[i]-'0';
                    i++;
                }
                i++;
                while(k[i]=='L'||k[i]=='R')//提取路径
                {
                    f=1;
                    b[bl++]=k[i];
                    i++;
                }
                if(f==0)//判断是否是根节点
                {
                    if(flag==0)//根节点只能存在一个
                    {
                        gen=num;
                        flag=1;
                    }
                    else fff=1;
                }
                else
                {
                    if(h.find(b)!=h.end())//判断路径是否重复
                        fff=1;
                    else
                    {
                        h.insert(b);
                        s[t].a=num;
                        strcpy(s[t].ss,b);
                        s[t++].al=strlen(b);
                    }
                }

            }
            while(scanf("%s",k));
        sort(s,s+t,cmp);//把节点按照层次顺序排列
        if(gen==-0x3f3f3f3f)fff=1;//不存在根节点的情况
        if(fff==1)printf("not complete\n");
        else
        {
            sum=0;
            dfs(0,"");
            if(sum!=t)fff=1;
            if(fff==1)printf("not complete\n");
            else
            {
                printf("%d",gen);
                for(int i=0; i<t; i++)
                    printf(" %d",s[i].a);
                printf("\n");
            }
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值