10106 - Product

 Product 

The Problem

The problem is to multiply two integers X, Y. (0<=X,Y<10250)

The Input

The input will consist of a set of pairs of lines. Each line in pair contains one multiplyer.

The Output

For each input pair of lines the output line should consist one integer the product.

Sample Input

12
12
2
222222222222222222222222

Sample Output

144
444444444444444444444444
 
代码:
#include<stdio.h>
#include<string.h>
#include<ctype.h>
int len1,len2,z,ans[1001],ans1[1001];
void fun(char x[1001],char y[1001])
{
 int i,j,k,c,bsum,t;
 for(i=0;i<len2;i++)
 {
  memset(ans1,0,sizeof(ans1));
  k=i;
  c=bsum=0;
  for(j=0;j<len1;j++)
  {
   bsum=c+(x[j]-'0')*(y[i]-'0');
   ans1[j+k]=bsum;
   c=bsum/10;
  }
  if(c>0)
   ans1[j+k]=c;
  c=bsum=0;
  for(t=0;t<1001;t++)
  {
   bsum=ans[t]+ans1[t]+c;
   ans[t]=bsum;
   c=bsum/10;
  }
 }
}
int main()
{
 int i,j;
 char x[1001],y[1001],x1[1001],y1[1001];
 while(scanf("%s%s",x,y)==2)
 {
  len1=strlen(x);
  len2=strlen(y);
        for(i=0,j=len1-1;i<len1;i++,j--)
   x1[j]=x[i];
  for(i=0,j=len2-1;i<len2;i++,j--)
   y1[j]=y[i];
  memset(ans,0,sizeof(ans));
  if(len1>=len2)fun(x1,y1);
  else
  {
   z=len1;
   len1=len2;
   len2=z;
   fun(y1,x1);
  }
  for(i=1000;i>=0;i--)
   if(ans[i]!=0)break; 
  if(i==-1)printf("0");
  for(i;i>=0;i--)
   printf("%d",ans[i]);
  printf("\n");  
 }
    return 0;
}
根据引用的内容,这段引用中包含了一些Vue.js代码和HTML代码,并讨论了换行符和空格在网页中的使用。其中,引用是关于添加和还原换行符的方法,引用是关于在编辑数据时获取详情和使用textarea的示例代码,引用是关于HTML中空格的处理和字符实体的使用。 问题中提到的&nbsp;是HTML中表示空格的字符实体。HTML通常会自动截取多余的空格,不管你加多少空格,都被看做一个空格。为了在网页中增加空格,可以使用&nbsp;表示空格。此外,还有其他常用的字符实体,如<表示小于号,>表示大于号,&表示&符号,"表示双引号,等等。 需要注意的是,引用的内容中有一些HTML实体被转义了,所以在描述字符实体时需要参考编码转义后的字符。 根据给定的引用内容,我无法直接回答问题,因为问题中的信息不完整。请提供更具体的问题或补充说明,我将尽力为您提供帮助。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *2* [js+v-html+正则表达式去除所有& nbsp和html标签(& nbsp 换行 )](https://blog.csdn.net/xm_w_xm/article/details/91992754)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v92^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] - *3* [html&nbsp;&nbsp;特殊字符(转)](https://blog.csdn.net/feiniu5566/article/details/13624619)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v92^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值