hdu1698-Just a Hook-线段树-整段区间的替换(延迟标记)

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=1698

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)



Problem Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

 


Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

 


Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

 


Sample Input

 
 
1 10 2 1 5 2 5 9 3

 

Sample Output
  
  
Case 1: The total value of the hook is 24.
 

题目大意
一根长n的武器,每一节可以选用金银铜三种材质,如果选金价值为3,选银价值为2,选铜价值为1,现在会进行m次选材料操作,问操作后价值为多少。一开始默认为铜制得。

解题思路
这道题可以用线段树来解, 线段树的成段代替,使用的是延迟标记(lazy)概念。延迟标记简单的讲就是先把满足查询区间的最大的区间标记并改变,它的所有子节点先不动,因为暂时用不到,等用得到的时候在将此标记传给下一层左右儿子,重复。
在discuss里还看到一个人写的是并查集,大概就是相当于分了三串,有三个代表元素。这里贴一个线段树的代码

代码
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
int col[800000];

struct node
{
    int l,r,sum;
}tree[800000];

void buildtree(int node,int b,int e)
{
    int mid=(b+e)/2;
    tree[node].l=b;
    tree[node].r=e;
    tree[node].sum=1;
    if(b==e) return;
    if(b<=mid) buildtree(node*2,b,mid);
    if(e>mid) buildtree(node*2+1,mid+1,e);
}
void push_down(int node)
{
    if(col[node])
    {
        col[node*2]=col[node*2+1]=col[node];//标记左右儿子
        tree[node*2].sum=col[node]*(tree[node*2].r-tree[node*2].l+1);//左右儿子的值要改变;
        tree[node*2+1].sum=col[node]*(tree[node*2+1].r-tree[node*2+1].l+1);
        col[node]=0;//取消这个标记
    }

}

void update(int node,int ql,int qr,int z)
{
    if(tree[node].l>=ql && tree[node].r<=qr)
    {
        col[node]=z;
        tree[node].sum=z*(tree[node].r-tree[node].l+1);
        return;//这一次不改变儿子的值
    }
    push_down(node);//把这个标记传下去给左右儿子
    int mid=(tree[node].l+tree[node].r)/2;
    if(ql<=mid) update(node*2,ql,qr,z);
    if(qr>mid) update(node*2+1,ql,qr,z);
    tree[node].sum=tree[node*2].sum+tree[node*2+1].sum;//把当前更改的值传给父亲
}

int main()
{
    int t,i;
    scanf("%d",&t);
    for(i=1;i<=t;++i)
    {
        int n;
        memset(col,0,sizeof(col));

        scanf("%d",&n);
        buildtree(1,1,n);

        int m;
        scanf("%d",&m);
        while(m--)
        {
            int x,y,z;
            scanf("%d%d%d",&x,&y,&z);
            update(1,x,y,z);
        }
        printf("Case %d: The total value of the hook is %d.\n",i,tree[1].sum);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值