hdu5904 BestCoder Round #87 LCIS -dp

LCIS

Problem Description

Alex has two sequences a1,a2,...,an and b1,b2,...,bm . He wants find a longest common subsequence that consists of consecutive values in increasing order.

 


Input

There are multiple test cases. The first line of input contains an integer T , indicating the number of test cases. For each test case:

The first line contains two integers n and m (1n,m100000) -- the length of two sequences. The second line contains n integers: a1,a2,...,an (1ai106) . The third line contains n integers: b1,b2,...,bm (1bi106) .

There are at most 1000 test cases and the sum of n and m does not exceed 2×106 .

 


Output

For each test case, output the length of longest common subsequence that consists of consecutive values in increasing order.

 


Sample Input

 
 
3 3 3 1 2 3 3 2 1 10 5 1 23 2 32 4 3 4 5 6 1 1 2 3 4 5 1 1 2 1

 


Sample Output

 
 
1 5 0

 


Source

BestCoder Round #87

 


Recommend

wange2014   |   We have carefully selected several similar problems for you:  5906 5905 5903 5902 5901 

 

题意

找a和b的最长公共上升子序列 并且这个子序列的值是递增的

解题思路

f分别用数组a,b表示以i为结尾的最长LCIS的长度,然后遍历一次,在满足a【i】==b【i】的前提下更新ans

或者 取max(ans,min(a[i],b[i]))一样

代码

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int maxn = 200000;
int a[maxn+5];//1串的桶,表示以i为结尾的最长LCIS的长度
int b[maxn+5];//2串的桶

int main()
{
    int T;
    scanf("%d", &T);
    while (T--) {
        int n, m,t;
        scanf("%d%d", &n, &m);

        memset(a, 0, sizeof(a));
        memset(b, 0, sizeof(b));
        for (int i = 0; i < n; i++)
        {
            scanf("%d", &t);
             a[t] = a[t-1] + 1;
        }
        for (int i = 0; i < m; i++)
        {
            scanf("%d", &t);
            b[t] = b[t-1] + 1;
        }

        int ans = -1;
        int mmin;
        for (int i = 0; i <maxn; i++) {
            mmin=min(a[i], b[i]);
            ans = max(ans, mmin);
        }
        printf("%d\n", ans);

    }
    return 0;
}

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值