hdu 5904 LCIS【dp】

LCIS

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 649    Accepted Submission(s): 303

Problem Description

Alex has two sequences a1,a2,...,an and b1,b2,...,bm. He wants find a longest common subsequence that consists of consecutive values in increasing order.

 

 

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains two integers n and m (1≤n,m≤100000) -- the length of two sequences. The second line contains n integers: a1,a2,...,an (1≤ai≤106). The third line contains n integers: b1,b2,...,bm (1≤bi≤106).

There are at most 1000 test cases and the sum of n and m does not exceed 2×106.

 

 

Output

For each test case, output the length of longest common subsequence that consists of consecutive values in increasing order.

 

 

Sample Input

3

3 3

1 2 3

3 2 1

10 5

1 23 2 32 4 3 4 5 6 1

1 2 3 4 5

1 1

2

1

 

 

Sample Output

1

5

0

 

 

Source

BestCoder Round #87

 

题目大意;

 

Alex有两个序列a_1,a_2,...,a_na1,a2,...,anb_1,b_2,...,b_mb1,b2,...,bm. 他想找到它们的最长公共递增子序列, 并且这个子序列的值是连续的(x,x+1,...,y-1,yx,x+1,...,y1,y).


思路:


1、定义dp【i】表示以数字i结尾的最长递增子序列长度。那么不难想到:dp【i】=max(dp【i】,dp【i-1】+1);


2、那么我们求出dpa【i】,dpb【i】,然后枚举答案即可。


Ac代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
int a[1000040];
int b[1000040];
int dpa[1000040];
int dpb[1000040];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            dpa[a[i]]=max(dpa[a[i]],dpa[a[i]-1]+1);
        }
        for(int i=0;i<m;i++)
        {
            scanf("%d",&b[i]);
            dpb[b[i]]=max(dpb[b[i]],dpb[b[i]-1]+1);
        }
        int ans=0;
        for(int i=0;i<n;i++)
        {
            ans=max(ans,min(dpa[a[i]],dpb[a[i]]));
        }
        printf("%d\n",ans);
        for(int i=0;i<n;i++)dpa[a[i]]=0;
        for(int i=0;i<m;i++)dpb[b[i]]=0;
    }
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值