Alignment(POJ--1836

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity. 

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line. 

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n). 

There are some restrictions: 
• 2 <= n <= 1000 
• the height are floating numbers from the interval [0.5, 2.5] 

Output

The only line of output will contain the number of the soldiers who have to get out of the line.
题意:有n个士兵站队,士兵都是按自己编号排的但不符合首领要求,首领要求每个人至少要看见队首或队尾并且编号顺序不能乱即整队只是让士兵站出来而不是所有的人都重新排队,求要使得符合首领要求站出来的士兵最少是多少人。
思路:先求出来从左向右的最长上升子序列,然后再求出来从右向左的最长上升子序列,然后再求这两个上升子序列的累加和求最大。前续最长上升子序列的最后一个人与后续最长上升子序列的最后一个人不一定是同一个人,也不一定挨着,有可能两者中间有不符合要求的人。

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4    
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
#define INF 0x3f3f3f3f
#define esp 1e-14
using namespace std;
int dpfront[1200],dpbehind[1200];
double a[1200];
int dcm(double x)                          //如果double型的x小于-esp则该函数返回值为-1;如果x>esp则该函数返回值为1;否则该函数返回值为0
{
    return x<-esp?-1:x>esp;
}
int main()
{
    //freopen("lalala.text","r",stdin);
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0; i<n; i++)
            scanf("%lf",&a[i]);
        memset(dpfront,0,sizeof(dpfront));
        memset(dpbehind,0,sizeof(dpbehind));
        dpfront[0]=1;                         //获取前续最长上升子序列
        for(int i=1; i<n; i++)
        {
            int flag=1;
            for(int j=i-1; j>=0; j--)
            {
                if(dcm(a[i]-a[j])>0)
                {
                    flag=0;
                    dpfront[i]=max(dpfront[i],dpfront[j]+1);
                }
            }
            if(flag)
                dpfront[i]=1;
        }
        dpbehind[n-1]=1;            //获取后续最长上升子序列
        for(int i=n-2; i>=0; i--)
        {
            int flag=1;
            for(int j=i+1; j<n; j++)
            {
                if(dcm(a[i]-a[j])>0)
                {
                    flag=0;
                    dpbehind[i]=max(dpbehind[i],dpbehind[j]+1);
                }
            }
            if(flag)
                dpbehind[i]=1;
        }
        int mm=-1;
        for(int i=0; i<n; i++)                  //枚举前续最长上升子序列
            for(int j=i+1; j<n; j++)           //枚举当前数后边的数的后续最长上升子序列
            {
                if((dpfront[i]+dpbehind[j])>mm)       //如果第i个数的前续最长上升子序列加上第j个数的后续最长上升子序列是最大的则以这两个人为中间的队伍是可以使站出去士兵最少的排队方式
                    mm=dpfront[i]+dpbehind[j];
            }
        if(dpfront[n-1]>mm)
            mm=dpfront[n-1];
        printf("%d\n",n-mm);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值