ACM: 最长升序和最长降序 dp题 poj…

                                                         Alignment

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity.

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line.

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n).

There are some restrictions:
• 2 <= n <= 1000
• the height are floating numbers from the interval [0.5, 2.5]

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8

1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4

 

题意: 士兵站队列. 要求至少的多少个出队列满足当前第i个士兵可以看到全部左边的队友或则全部右边的队友.

 

解题思路:

                1. 模型还是挺熟悉的. 最长升序和最长降序. dp问题.

                2. 设dp1[i]表示当前第i个前序中,最大的满足升序元素个数.

                      dp2[i]表示当前第i个以后直到序列结束,最大的满足降序元数个数.

                3. 最后将两个dp1 , dp2集合合并寻找出最大的子集序列, 同时满足最大升序或则最大将序.

                    合并证明就自己理解咯.不证明. 结果n - merge(e); 就是最少出队个数.

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
#define MAX 1005

int n;
double a[MAX];
int dp1[MAX];
int dp2[MAX];

int main()
{
//    freopen("input.txt","r",stdin);
    while(scanf("%d",&n) != EOF)
    {
        for(int i = 1; i <= n; ++i)
            scanf("%lf",&a[i]);
        memset(dp1,0,sizeof(dp1));
        memset(dp2,0,sizeof(dp2));
        
        dp1[1] = 1;
        for(int i = 2; i <= n; ++i)
        {
            dp1[i] = 1;
            for(int j = i-1; j >= 1; --j)
            {
                if(a[i] > a[j] && dp1[i] < dp1[j]+1)
                {
                    dp1[i] = dp1[j]+1;
                }
            }
        }
        
        dp2[n] = 1;
        for(int i = n; i >= 1; --i)
        {
            dp2[i] = 1;
            for(int j = i+1; j <= n; ++j)
            {
                if(a[i] > a[j] && dp2[i] < dp2[j]+1)
                {
                    dp2[i] = dp2[j]+1;
                }
            }
        }
        
        int ans = dp1[n];
        for(int i = 1; i < n; ++i)
        {
            for(int j = i+1; j <= n; ++j)
            {
                if(ans < dp1[i] + dp2[j])
                    ans = dp1[i]+dp2[j];
            }
        }
        printf("%d\n",n-ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值