hdu 6075-Questionnaire

Problem Description
In order to get better results in official ACM/ICPC contests, the team leader comes up with a questionnaire. He asked everyone in the team whether to have more training.

Picture from Wikimedia Commons

Obviously many people don’t want more training, so the clever leader didn’t write down their words such as ”Yes” or ”No”. Instead, he let everyone choose a positive integer ai to represent his opinion. When finished, the leader will choose a pair of positive interges m(m > 1) and k(0≤ k < m), and regard those people whose number is exactly k modulo m as ”Yes”, while others as ”No”. If the number of ”Yes” is not less than ”No”, the leader can have chance to offer more training.

Please help the team leader to find such pair of m and k.

Input
The first line of the input contains an integer T(1≤T≤15), denoting the number of test cases.

In each test case, there is an integer n(3≤n≤100000) in the first line, denoting the number of people in the ACM/ICPC team.

In the next line, there are n distinct integers a1,a2,…,an(1≤ai≤109), denoting the number that each person chosen.

Output
For each test case, print a single line containing two integers m and k, if there are multiple solutions, print any of them.

Sample Input
1
6
23 3 18 8 13 9

Sample Output
5 3

首先 题目不难理解
在 一定集训的情况下, 在给出的 数组a[1000]里面 找出 1个 m和k 满足 kk=a[i]%m k即为kk里出现次数最多的那一个

但是 题目 中有一句话 需要注意
if there are multiple solutions, print any of them.
如果多解 输出 其中一种
样例输出 有什么用 。。。。。

最简单满足情况的 就是 直接对2 取余 那么 就只有 0,1 两种情况了

直接上代码

#include<cstdio>
#include<iostream>
#include<bits/stdc++.h>
using namespace std;
const int  Max = 100001;
typedef long long LL;
int a[Max];
int b[Max];
int main()
{
    int N;
    scanf("%d",&N);
    while (N--)
    {
        int n;
        scanf("%d",&n);
        int t=0,t1=0;
        for (int i=0; i<n; i++)
        {
             scanf("%d",&a[i]);
             if (a[i]%2==0)
                t++;
             else
                t1++;
        }
         printf("2 ");
        if (t>=t1)
            printf("0\n");
        else
            printf("1\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值