HDU 6077 Time To Get Up【模拟题】【水题】

Time To Get Up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 364    Accepted Submission(s): 288


Problem Description
Little Q's clock is alarming! It's time to get up now! However, after reading the time on the clock, Little Q lies down and starts sleeping again. Well, he has  5 alarms, and it's just the first one, he can continue sleeping for a while.

Little Q's clock uses a standard 7-segment LCD display for all digits, plus two small segments for the '':'', and shows all times in a 24-hour format. The '':'' segments are on at all times.



Your job is to help Little Q read the time shown on his clock.
 

Input
The first line of the input contains an integer  T(1T1440), denoting the number of test cases.

In each test case, there is an  7×21 ASCII image of the clock screen.

All digit segments are represented by two characters, and each colon segment is represented by one character. The character ''X'' indicates a segment that is on while ''.'' indicates anything else. See the sample input for details.
 

Output
For each test case, print a single line containing a string  t in the format of  HH:MM, where  t(00:00t23:59), denoting the time shown on the clock.
 

Sample Input
 
  
1 .XX...XX.....XX...XX. X..X....X......X.X..X X..X....X.X....X.X..X ......XX.....XX...XX. X..X.X....X....X.X..X X..X.X.........X.X..X .XX...XX.....XX...XX.
 

Sample Output
 
  
02:38
 

Source

对数字的特征进行一下判断即可。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <cstring>
#define INF 0x3f3f3f3f
#define ms(x,y) memset(x,y,sizeof(x))
using namespace std;

typedef long long ll;

const double pi = acos(-1.0);
const double eps = 1e-8;
const int maxn = 1e6 + 10;

char a[10][30] = { 0 };

int solve(int p)
{
	if (a[3][p + 1] == '.')
	{
		if (a[6][p + 1] == 'X') return 0;
		if (a[0][p + 1] == 'X') return 7;
		return 1;
	}
	if (a[1][p] == '.')
	{
		if (a[4][p] == 'X') return 2;
		return 3;
	}
	if (a[1][p + 3] == '.')
	{
		if (a[4][p] == '.') return 5;
		return 6;
	}
	if (a[4][p] == '.')
	{
		if (a[6][p + 1] == '.') return 4;
		return 9;
	}
	return 8;
}

int main()
{
	int t;
	scanf("%d", &t);
	while (t--)
	{
		ms(a, 0);
		for (int i = 0; i < 7; i++)
		{
			for (int j = 0; j < 21; j++)
			{
				scanf(" %c", &a[i][j]);
			}
		}
		int h1, h2, m1, m2;
		for (int i = 0; i < 4; i++)
		{
			int p;
			if (i == 0) p = 0;
			else if (i == 1) p = 5;
			else if (i == 2) p = 12;
			else p = 17;
			if (i == 0) h1 = solve(p);
			else if (i == 1) h2 = solve(p);
			else if (i == 2) m1 = solve(p);
			else m2 = solve(p);
		}
		printf("%d%d:%d%d\n", h1, h2, m1, m2);
	}
	return 0;
}






转载于:https://www.cnblogs.com/Archger/p/8451614.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值