HDU 6095 Rikka with Competition -2017多校联盟5 第11题

Rikka with Competition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 4    Accepted Submission(s): 4


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

A wrestling match will be held tomorrow. n players will take part in it. The i th player’s strength point is ai .

If there is a match between the i th player plays and the j th player, the result will be related to |aiaj| . If |aiaj|>K , the player with the higher strength point will win. Otherwise each player will have a chance to win.

The competition rules is a little strange. Each time, the referee will choose two players from all remaining players randomly and hold a match between them. The loser will be be eliminated. After n1 matches, the last player will be the winner.

Now, Yuta shows the numbers n,K and the array a and he wants to know how many players have a chance to win the competition.

It is too difficult for Rikka. Can you help her?  
 

Input
The first line contains a number t(1t100) , the number of the testcases. And there are no more than 2 testcases with n>1000 .

For each testcase, the first line contains two numbers n,K(1n105,0K<109) .

The second line contains n numbers ai(1ai109) .
 

Output
For each testcase, print a single line with a single number -- the answer.
 

Sample Input
  
  
2 5 3 1 5 9 6 3 5 2 1 5 9 6 3
 

Sample Output
  
  
5 1
 

Source



/*
n个人每个人的能力是ai,当|ai-aj|>k时,能力大的人赢。否则两个人都可能赢
n-1场比赛,每个人都等可能的跟别人打架,问最后可能赢的人数

题解:
把能力排序,两两之间算差,如果此人和前一个人能力差>k时,
前者一定输并且前面人中不可能有打得过此人的,那么只有此人可能赢
从左到右枚举一下即可
*/
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

const int maxn = 1e5 + 10;

int a[maxn];
int n, k;

int main()
{
    int t;

    scanf("%d", &t);
    while (t > 0)
    {
        t--;

        scanf("%d%d", &n, &k);

        for (int i=0; i<n; i++) scanf("%d", &a[i]);

        sort(a, a+n);

        int cnt = 1;
        for (int i=1; i<n; i++){
            if (a[i]-a[i-1] > k){
                cnt = 1;
                continue;
            }
            cnt++;
        }
        cout << cnt << endl;
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值