1007. Maximum Subsequence Sum (25)
Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.
Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:10 -10 1 2 3 4 -5 -23 3 7 -21Sample Output:
10 1 4
/**
题意:
n个数的序列,找最大子序列和,并且输出这个子序列的开头和尾
如果全是负数则规定和为0并输出整个序列的头和尾
*/
#include <cstdio>
#include <cassert>
#include <iostream>
#include <queue>
#include <algorithm>
using namespace std;
const int INF = 0x3f3f3f3f;
const int maxn = 10000 + 5;
int main() {
int n;
int a[maxn];
int summax = -INF,nowmax = 0,nowb,nowe,sumb,sume;
cin>>n;
for(int i = 0;i<n;++i){
scanf("%d",&a[i]);
}
for(int i = 0;i<n;++i){
if(nowmax<=0) {
nowmax = a[i];
nowb = i;
nowe = i;///重新开始,起终点都是这个数
}
else{
nowmax += a[i];
nowe = i;
}
if(nowmax > summax) {
summax = nowmax;
sumb = nowb;
sume = nowe;
}
}
if(summax <0){///没有正数
printf("0 %d %d",a[0],a[n-1]);
}else
printf("%d %d %d",summax,a[sumb],a[sume]);
return 0;
}