PAT甲级1007 Maximum Subsequence Sum(最大子串和)

1007 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

 

求最大子串和并输出位置,因为是子串和,我们只要从头到位不停地累加,当发现前面的累加加上该数字之后整体的结果小于0了,那么意味着前面的求和加到这里就没有意义了,那么就需要从该数字开始重新开始累加。

 

#include<bits/stdc++.h>
using namespace std;
int main(){
	int n;
	cin>>n;
	int a[11111];
	for(int i=1;i<=n;i++)
	cin>>a[i];
	int dp[11111];
	memset(dp,0,sizeof(dp));
	int ans=0;
	int f=1;
	dp[0]=-1;
	for(int i=1;i<=n;i++)
	{
		if(a[i]>=0)f=0;
		if(dp[i-1]<0)
		{
			dp[i]=a[i];
		}
		else{
			dp[i]=dp[i-1]+a[i];
		}
		ans=max(ans,dp[i]);
	}
	if(ans==0&&f==1)
	{
		cout<<ans<<" "<<a[1]<<" "<<a[n]<<endl;
	}
	else{
		cout<<ans<<" ";
		for(int i=1;i<=n;i++)
		{
			if(dp[i]==ans)
			{
				int j=i;
				while(dp[j]>=0)
				{
					j--;
					if(j<0)break;
				}
				cout<<a[j+1]<<" "<<a[i]<<endl;
				break;
			}
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值