Project facet Java version 1.8 is not supported解决方法

标签: java
4人阅读 评论(0) 收藏 举报
分类:

方法一:
右击项目 选择Properties , 再选择 Project Facets,右击选择 Java ,修改Version
这里写图片描述

方法二:
在该项目的目录下有一个.settings的文件夹,文件夹下有一个org.eclipse.wst.common.project.facet.core.xml文件,内容如下;

<?xml version="1.0" encoding="UTF-8"?>
<faceted-project>
  <runtime name="Apache Tomcat v7.0"/>
  <fixed facet="java"/>
  <fixed facet="wst.jsdt.web"/>
  <fixed facet="jst.web"/>
  <installed facet="java" version="1.8"/>
  <installed facet="jst.web" version="2.5"/>
  <installed facet="wst.jsdt.web" version="1.0"/>
</faceted-project>

修改 java的version为1.7即可,既:

<installed facet="java" version="1.7"/>
查看评论

Project facet Java version 1.8 is not supported解决记录

一看知道是因为jdk版本不一致所导致,如何解决?方法一:选中项目 Properties , 选择 Project Facets,右击选择 Java , Change Version 方法二:在 项目...
  • dingchenxixi
  • dingchenxixi
  • 2016年05月25日 11:21
  • 39158

project facet java 1.8 is not supported解决办法

本文转自:http://blog.163.com/zhengjiu_520/blog/static/35598306201218420230/
  • thelastperfect
  • thelastperfect
  • 2014年11月20日 17:42
  • 6051

解决eclipse中web项目出现Project facet Java version 1.8 is not supported.的问题

项目的jdk和tomcat的jdk版本不同,将eclipse-preference-server-runtime environments点击你要用的tomcat点击edit-jre选择和你项目对应的...
  • sinat_33819452
  • sinat_33819452
  • 2016年09月09日 16:21
  • 4523

Eclipse Tomcat Project facet Java version 1.8 is not supported

如图,web部署到tomcat的时候报错。因为jdk版本是tomcat需要的版本不匹配。 办法: 点击工程 -> Properties -> Project Facte ...
  • hwjean
  • hwjean
  • 2016年09月13日 15:15
  • 984

Project facet Java version 6.0 is not supported.解决办法

今天从svn上取了项目之后,为它添加server的时候,出现Project facet Java version 6.0 is not supported. 上网搜了一下,找到以下办法: 这个问题遇到...
  • soconglin
  • soconglin
  • 2011年05月09日 10:21
  • 3307

Project facet java version 1.8 is not supported

eclipse添加项目到tomcat报错:Project facet java version 1.8 is not supported 说明项目是其他版本jdk编译的,在eclipse里运行时...
  • levi_work
  • levi_work
  • 2015年07月28日 13:43
  • 807

eclipse 项目提示"Project facet Java version 1.8 is not supported"

今天使用eclipse 工具,导入maven 项目,编译项目的时候提示"Project facet Java version 1.8 is not supported"。 第一步:排查eclipse...
  • zhouzhiwengang
  • zhouzhiwengang
  • 2016年12月06日 21:33
  • 2061

04-Eclipse导入项目--facet版本问题:Project facet Java version 1.8 is not supported

facet问题:Project facet Java version 1.8 is not supported
  • baidu_37107022
  • baidu_37107022
  • 2017年05月15日 11:46
  • 764

eclispe无法运行java web程序—提示:Project facet Java version 1.7 is not supported

重装eclispe,重新配置tomcat,在eclispe中配置tomcat。配置一切顺利,配置完毕检验。    新建java web程序,然后进行测试。    在eclispe中,新建java ...
  • llhhyy1989
  • llhhyy1989
  • 2012年03月12日 16:30
  • 18534

错误记录--Project facet Java 5.0 is not supported by target runtime Apache Tomcat v5.5

错误信息:Project facet Java 5.0 is not supported by target runtime Apache Tomcat v5.5.在工程目录下的.settings文件...
  • xinxin19881112
  • xinxin19881112
  • 2011年01月18日 01:29
  • 2751
    个人资料
    等级:
    访问量: 179
    积分: 220
    排名: 90万+
    文章分类
    文章存档