HDU-3507-Print Article-斜率优化-DP

题目:


Problem Description
Zero has an old printer that doesn't work well sometimes. As it is antique, he still like to use it to print articles. But it is too old to work for a long time and it will certainly wear and tear, so Zero use a cost to evaluate this degree.
One day Zero want to print an article which has N words, and each word i has a cost Ci to be printed. Also, Zero know that print k words in one line will cost

M is a const number.
Now Zero want to know the minimum cost in order to arrange the article perfectly.
 

Input
There are many test cases. For each test case, There are two numbers N and M in the first line (0 ≤ n ≤  500000, 0 ≤ M ≤ 1000). Then, there are N numbers in the next 2 to N + 1 lines. Input are terminated by EOF.
 

Output
A single number, meaning the mininum cost to print the article.
 

Sample Input
  
  
5 5 5 9 5 7 5
 

Sample Output
  
  
230
 



思路:简单的斜率优化

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<queue>
using namespace std;
#define maxn 500050
int dp[maxn];
int gg[maxn];
int sum[maxn];
int n,m;
int getDP(int i,int j) {    //求出连续区间的一段值.即最基本的DP方法。
    return dp[j]+m+(sum[i]-sum[j])*(sum[i]-sum[j]);
}
int getUP(int j,int k) {    //斜率上部分
    return dp[j]+sum[j]*sum[j]-(dp[k]+sum[k]*sum[k]);
}
int getDOWN(int j,int k) {  //斜率下部分
    return 2*(sum[j]-sum[k]);
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF) {
        memset(sum,0,sizeof sum);
        memset(dp,0,sizeof dp);
        for(int i=1;i<=n;i++)
           scanf("%d",&sum[i]);
        for(int i=1;i<=n;i++)
           sum[i]+=sum[i-1];
        int head=0,wei=1;
        gg[1]=0;
        for(int i=1;i<=n;i++) {
            while(head+1<wei&&getUP(gg[head+1],gg[head])<=sum[i]*getDOWN(gg[head+1],gg[head]))
               head++;
            //排除第一种情况
            dp[i]=getDP(i,gg[head]);
            while(head+1<wei&&getUP(i,gg[wei-1])*getDOWN(gg[wei-1],gg[wei-2])<=getUP(gg[wei-1],gg[wei-2])*getDOWN(i,gg[wei-1]))
                    wei--;
            //排除第二种情况
            gg[wei++]=i;
        }
        printf("%d\n",dp[n]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值