【欧拉函数】Bi-shoe and Phi-shoe【LightOJ1370】------长篇阅读专场D题

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,
Score of a bamboo = Φ (bamboo’s length)
(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.
The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.
Input
Input starts with an integer T (≤ 100), denoting the number of test cases.
Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].
Output
For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.
Sample Input
3
5
1 2 3 4 5
6
10 11 12 13 14 15
2
1 1
Sample Output
Case 1: 22 Xukha
Case 2: 88 Xukha
Case 3: 4 Xukha

解题思路:
这道题要用到欧拉函数的知识。
http://blog.csdn.net/sentimental_dog/article/details/52002608
但是我做的时候直接用素数筛法打表,然后输出大于等于输入的最小素数的和,就可以了。
这种做法是投机取巧的,正确做法还是应该用筛法求欧拉函数。
要注意,最后输出很大,必须用long long int型,否则会WA。

#include<stdio.h>
#include<iostream>
using namespace std; 

int input[10010];
int prime[1001000]={0};
long long int ans;

void isprime()//用筛法将素数打表
{
    prime[1]=1;
    for(int i=2;i<=1001000;i++)
    {
        if(prime[i]==0)
        {
            for(int j=2*i;j<=1001000;j+=i)
            {
                prime[j]=1;
            }
        }
    }
}

int main()
{
    int t;
    isprime();
    scanf("%d",&t);
    for(int i=1;i<=t;i++)
    {
        int n;
        scanf("%d",&n);
        for(int j=1;j<=n;j++)
        {
            scanf("%d",&input[j]);
        }
        ans=0;
        for(int j=1;j<=n;j++)
        {
            int k=input[j]+1;
            while(1)
            {
                if(prime[k]==0)
                {
                    ans+=k;
                    break;
                }
                k++;
            }
        }
        cout<<"Case "<<i<<": "<<ans<<" Xukha"<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值