1370 - Bi-shoe and Phi-shoe
Time Limit:2000MS Memory Limit:32768KB 64bit IO Format:%lld & %llu
Description
Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,
Score of a bamboo = Φ (bamboo's length)
(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.
The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.
Input
Input starts with an integer T (≤ 100), denoting the number of test cases.
Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].
Output
For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.
Sample Input
3
5
1 2 3 4 5
6
10 11 12 13 14 15
2
1 1
Sample Output
Case 1: 22 Xukha
Case 2: 88 Xukha
Case 3: 4 Xukha
题意:给你n个数a,然后求出最小的eular(i)>a,然后求和
思路:典型的欧拉筛,注意的是要从a+1开始寻找,因为有1的因素
总结:经典应用,不难
ac代码:
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stack>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#define MAXN 1010000
#define LL long long
#define ll __int64
#define INF 0xfffffff
#define mem(x) memset(x,0,sizeof(x))
#define PI acos(-1)
using namespace std;
LL ans[MAXN];
void db()
{
memset(ans,0,sizeof(ans));
ans[1]=1;
int i,j;
for(i=2;i<=MAXN;i++)
{
if(!ans[i])
{
for(j=i;j<=MAXN;j+=i)
{
if(!ans[j])
ans[j]=j;
ans[j]=ans[j]/i*(i-1);
}
}
}
}
int main()
{
int t,n,m,i,j,k;
int cas=0;
db();
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
ll sum=0;
for(i=0;i<n;i++)
{
int a;
scanf("%d",&a);
int x=a+1;
while(ans[x]<a)
x++;
printf("x=%d\n",x);
sum+=x;
}
printf("Case %d: %lld Xukha\n",++cas,sum);
}
return 0;
}