//十进制转千进制//同余模定理//The Embarrassed Cryptographer------二H题

The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users, which is now in use in his company. The cryptographic keys are created from the product of two primes, and are believed to be secure because there is no known method for factoring such a product effectively.
What Odd Even did not think of, was that both factors in a key should be large, not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired, Odd Even secretly goes through all the users keys, to check if they are strong enough. He uses his very poweful Atari, and is especially careful when checking his boss’ key.
Input
The input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10 100 and 2 <= L <= 10 6. K is the key itself, a product of two primes. L is the wanted minimum size of the factors in the key. The input set is terminated by a case where K = 0 and L = 0.
Output
For each number K, if one of its factors are strictly less than the required L, your program should output “BAD p”, where p is the smallest factor in K. Otherwise, it should output “GOOD”. Cases should be separated by a line-break.
Sample Input
143 10
143 20
667 20
667 30
2573 30
2573 40
0 0
Sample Output
GOOD
BAD 11
GOOD
BAD 23
GOOD
BAD 31

解题思路:
用同余模定理求一个大数的模。
十进制超时的话,可以先转成千进制。
模板大致如下:
for(int i=1;i<=len;i++)
{
res=(res*1000+m[i])%n;
}

#include<stdio.h>
#include<string.h>

int prime[1001000]={0};

void init()//用筛法素数打表
{
    prime[1]=1;
    for(int i=2;i<1001000;i++)
    {
        if(prime[i]==0)
        {
            for(int j=i*2;j<1001000;j+=i)
            {
                prime[j]=1;
            }
        }
    }
}

bool mod(int *m,int n,int len)
//同余模定理,如果能整除返回true,不能整除返回false
{
    int res=0;
    for(int i=1;i<=len;i++)
    {
        res=(res*1000+m[i])%n;
    }
    if(res==0)
    {
        return true;
    }
    else
    {
        return false;
    }
}

int main()
{
    char k[110];
    int l;
    int thou[40];
    init();
    while(1)
    {
        memset(k,0,sizeof(k));
        memset(thou,0,sizeof(thou));
        scanf("%s%d",k,&l);
        if(k[0]=='0'&&strlen(k)==1&&l==0)
        {
            return 0;
        }
        int start;
        int cnt;
        int len=strlen(k);
        if(len%3==1)
        {
            thou[1]=k[0]-'0';
            start=1;
            cnt=2;
        }
        else if(len%3==2)
        {
            thou[1]=(k[0]-'0')*10+k[1]-'0';
            start=2;
            cnt=2;
        }
        else
        {
            start=0;
            cnt=1;
        }
        for(int i=start;i<len;i+=3)
        {
            thou[cnt++]=(k[i]-'0')*100+(k[i+1]-'0')*10+k[i+2]-'0';
        }
        //把字符串转换成千进制数字,存到数组里
        //比如“123456789”---thou[123][456][789]
        int flag=1;
        for(int i=2;i<l;i++)//从1到l遍历
        {
            if(prime[i]==0)//是素数
            {
                if(mod(thou,i,cnt-1)==true)//检查能否同除
                {
                    printf("BAD %d\n",i);
                    flag=0;
                    break;
                }
            }
        }
        if(flag==1)
        {
            printf("GOOD\n");
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值