poj2635——The Embarrassed Cryptographer(高精度取模)

Description

The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users, which is now in use in his company. The cryptographic keys are created from the product of two primes, and are believed to be secure because there is no known method for factoring such a product effectively.
What Odd Even did not think of, was that both factors in a key should be large, not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired, Odd Even secretly goes through all the users keys, to check if they are strong enough. He uses his very poweful Atari, and is especially careful when checking his boss’ key.
Input

The input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10100 and 2 <= L <= 106. K is the key itself, a product of two primes. L is the wanted minimum size of the factors in the key. The input set is terminated by a case where K = 0 and L = 0.
Output

For each number K, if one of its factors are strictly less than the required L, your program should output “BAD p”, where p is the smallest factor in K. Otherwise, it should output “GOOD”. Cases should be separated by a line-break.
Sample Input

143 10
143 20
667 20
667 30
2573 30
2573 40
0 0
Sample Output

GOOD
BAD 11
GOOD
BAD 23
GOOD
BAD 31

给出两个数S和L,S是一个非常大的数,L是一个整形数,S是由两个素数相乘得到的,求这两个素数中是否有一个小于L,如果有,输出BAD和这个数,没有就输出GOOD
设S中有一个素数是P,那么S%P一定等于0,并且这个P的范围不会超过L,所以完全可以一个个试出来。剩下的问题就是如果处理大数S,我用了分段的方法,每三位就存在一个数组里

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
//#include <map>
#include <cmath>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 1000005
#define Mod 10001
using namespace std;
bool notprime[MAXN];
int primes[700005]; //素数从i=1开始
void get_prime()
{
    notprime[1]=true;
    for(int i=2;i<MAXN;++i)
    if(!notprime[i])
    {
        primes[++primes[0]]=i;
        for(long long j=(long long)i*i;j<MAXN;j+=i)
        notprime[j]=true;
    }
}
int bignum[MAXN];
int main()
{
    get_prime();
    string s;
    int l;
    while(cin>>s>>l)
    {
        if(s[0]=='0'&&l==0)
            break;
        int len=s.length(),sum=0,k=0,tmp,wei=0;
        for(int i=len-1;i>=0;--i)
        {
            tmp=s[i]-'0';
            for(int j=1;j<=wei;++j)
                tmp*=10;
            sum+=tmp;
            wei++;
            if(wei==3)
            {
                bignum[k++]=sum;
                sum=0;
                wei=0;
            }
        }
        if(sum!=0)
            bignum[k++]=sum;
        int p,flag=0;
        for(int i=1;i<=MAXN;++i)
        {
            p=primes[i];
            if(p>=l)
                break;
            tmp=0;
            for(int j=k-1;j>=0;--j)
                tmp=(tmp*1000+bignum[j])%p;
            if(tmp==0)
            {
                printf("BAD %d\n",p);
                flag=1;
                break;
            }
        }
        if(!flag)
            printf("GOOD\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值