//优先队列和k路归并和序列的前n小元素//Sequence------三D

Given m sequences, each contains n non-negative integer. Now we may select one number from each sequence to form a sequence with m integers. It’s clear that we may get n ^ m this kind of sequences. Then we can calculate the sum of numbers in each sequence, and get n ^ m values. What we need is the smallest n sums. Could you help us?
Input
The first line is an integer T, which shows the number of test cases, and then T test cases follow. The first line of each case contains two integers m, n (0 < m <= 100, 0 < n <= 2000). The following m lines indicate the m sequence respectively. No integer in the sequence is greater than 10000.
Output
For each test case, print a line with the smallest n sums in increasing order, which is separated by a space.
Sample Input
1
2 3
1 2 3
2 2 3
Sample Output
3 3 4

http://blog.csdn.net/winddreams/article/details/38375563
http://blog.csdn.net/MIKASA3/article/details/54800359
解题思路:
这里写图片描述
这里写图片描述
输入一组处理一组,先求出前两组数的n个最小和,再输入一组数,将这组数与前面的n个最小和一起处理,再求出这两组数的n个最小和…………直到m组数全部输入处理完毕。

#include<stdio.h>
#include<queue>
#include<algorithm>
using namespace std;

int a[2010],b[2010];

int main()
{
    int t,i,j,temp;
    scanf("%d",&t);
    while(t--)
    {
        int m,n;
        scanf("%d%d",&m,&n);

        priority_queue<int> q;

        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        sort(a+1,a+n+1);

        m--;
        while(m--)
        {
            for(i=1;i<=n;i++)
            {
                scanf("%d",&b[i]);
            }
            sort(b+1,b+n+1);

            for(i=1;i<=n;i++)
            {
                q.push(a[i]+b[1]);
            }

            for(j=2;j<=n;j++)
            {
                for(i=1;i<=n;i++)
                {
                    temp=a[i]+b[j];
                    if(temp>=q.top())break;
                    else
                    {
                        q.pop();
                        q.push(temp);
                    }
                }
            }

            for(i=n;i>=1;i--)
            {
                a[i]=q.top();
                q.pop();
            }
        }
        for(i=1;i<n;i++)
            printf("%d ",a[i]);
        printf("%d\n",a[n]);
    }
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值