poj2442 Sequence

Sequence
Time Limit: 6000MS Memory Limit: 65536K
Total Submissions: 8887 Accepted: 2953

Description

Given m sequences, each contains n non-negative integer. Now we may select one number from each sequence to form a sequence with m integers. It's clear that we may get n ^ m this kind of sequences. Then we can calculate the sum of numbers in each sequence, and get n ^ m values. What we need is the smallest n sums. Could you help us?

Input

The first line is an integer T, which shows the number of test cases, and then T test cases follow. The first line of each case contains two integers m, n (0 < m <= 100, 0 < n <= 2000). The following m lines indicate the m sequence respectively. No integer in the sequence is greater than 10000.

Output

For each test case, print a line with the smallest n sums in increasing order, which is separated by a space.

Sample Input

1
2 3
1 2 3
2 2 3

Sample Output

3 3 4

题目大意:给你m个序列,每次从每个序列里挑选一个数组成一个新的序列,每个序列进行加和组成一个新的序列,然后输出前n小的序列。

对于两个序列我们就可以a[0]+b[0],a[1]+b[0]一直到a[n-1]+b[0],然后是依次加a[1],这样我们就可以得到一个新的序列,如果只有两个序列,那我们的序列就是符合条件的,如果对于三个序列那就是两个序列组成的新序列看成新的a序列,第三个序列就是b序列,想一想,是不是?

这样依次迭代,到最后就是所求的m个序列组成的新序列,如果我们全部暴力存储,显然时间和空间开销都是非常大的,到最后跟直接m个序列暴力是没有区别的,达到n^m。

╮(╯▽╰)╭人家也没让你求辣么多啊,每次维护长为n的数组就可以啦

这里我用一个优先队列来维护哒464ms才

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <vector>
#include <map>
#include <queue>
using namespace std;
const int MAXN=2000+10;
const int inf=0x3f3f3f;
int a[MAXN],b[MAXN],c[MAXN];
int n,m;
void del()
{
    int i,j;
    priority_queue<int>q;
    for(i=0;i<n;++i)//先读入n个元素
    {
        q.push(a[i]+b[0]);
    }
    for(i=1;i<n;++i)//维护队列
    {
        for(j=0;j<n;++j)
        {
            int x=a[j]+b[i];
            if(x<q.top())//如果比最大值还小,就进队,大的出队
            {
                q.pop();
                q.push(x);
            }
            else break;//否则的话,后面一定都比x大的,所以直接break
        }
    }

    for(i=0;i<n;++i)
    {
        a[n-1-i]=q.top();//更新a数组
        q.pop();
    }

}
int main()
{
    int t;
    int i,j;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&m,&n);
        for(j=0;j<n;++j)scanf("%d",&a[j]);
        sort(a,a+n);
        for(i=1;i<m;++i)
        {
            for(j=0;j<n;++j)scanf("%d",&b[j]);
            sort(b,b+n);
            del();
        }
        for(i=0;i<n-1;++i)printf("%d ",a[i]);
        printf("%d\n",a[n-1]);
    }
    return 0;
}



  • 3
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值