//树形结构的dfs//poj3140//Contestants Division------三X

In the new ACM-ICPC Regional Contest, a special monitoring and submitting system will be set up, and students will be able to compete at their own universities. However there’s one problem. Due to the high cost of the new judging system, the organizing committee can only afford to set the system up such that there will be only one way to transfer information from one university to another without passing the same university twice. The contestants will be divided into two connected regions, and the difference between the total numbers of students from two regions should be minimized. Can you help the juries to find the minimum difference?
Input
There are multiple test cases in the input file. Each test case starts with two integers N and M, (1 ≤ N ≤ 100000, 1 ≤ M ≤ 1000000), the number of universities and the number of direct communication line set up by the committee, respectively. Universities are numbered from 1 to N. The next line has N integers, the Kth integer is equal to the number of students in university numbered K. The number of students in any university does not exceed 100000000. Each of the following M lines has two integers s, t, and describes a communication line connecting university s and university t. All communication lines of this new system are bidirectional.
N = 0, M = 0 indicates the end of input and should not be processed by your program.
Output
For every test case, output one integer, the minimum absolute difference of students between two regions in the format as indicated in the sample output.
Sample Input
7 6
1 1 1 1 1 1 1
1 2
2 7
3 7
4 6
6 2
5 7
0 0
Sample Output
Case 1: 1

解题思路:
因为没学过“树”,所以完全不会做,到网上找了答案,但是连答案都看不懂。不懂的主要是输入路径的部分和深搜的部分,花了很久才勉强看懂,把想法写在下面的注释里了。现在对树只有模糊的认识,还不清晰,还要再认真学习一下这个数据结构。

#include<stdio.h>
#include<memory.h>

struct node
{
    int cur,next;
}edge[1000010];

int head[100010];
int num[100010];
long long sum,ans;

long long abs(long long a)
{
    if(a>=0)
        return a;
    else
        return -a;
}

long long dfs(int u,int root)
{
    long long dp=0;  
    int pos=head[u];  
    while (pos!=-1)  
    {  
        int v=edge[pos].cur;  
        if(v!=root)  
            dp+=dfs(v,u);  
    //如果和u相连的节点不只有一个root(第一个不是root),则把u当成root深搜,直到root只有一个孩子(与u相连的只有root)。
        pos=edge[pos].next;  
    }  
    dp+=num[u];  //把根节点的值加上
    if(abs(sum-2*dp)<ans) 
        ans=abs(sum-2*dp);  
    return dp;
}

int main()
{
    int n,m,u,v,cnt,count=0;
    while(1)
    {
        cnt=0;
        sum=0;
        memset(head,-1,sizeof(head));
        scanf("%d%d",&n,&m);
        if(n==0&&m==0)
        {
            break;
        }
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&num[i]);
            sum+=num[i];
        }
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&u,&v);
            edge[cnt].cur=u;
            edge[cnt].next=head[v];
            head[v]=cnt++;
            edge[cnt].cur=v;
            edge[cnt].next=head[u];
            head[u]=cnt++;
        }
        //这么存最后的结果就是,能顺着head[i]和edge.next找到所有直接连着i的节点。edge[head[i]].cur是第一个,然后是edge[edge[head[i].next].cur,以此类推。
        ans=sum;
        dfs(1,-1);
        printf("Case %d: %lld\n",++count,ans);  
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值