//完全背包//hdu2063//investment------四D

John never knew he had a grand-uncle, until he received the notary’s letter. He learned that his late grand-uncle had gathered a lot of money, somewhere in South-America, and that John was the only inheritor.
John did not need that much money for the moment. But he realized that it would be a good idea to store this capital in a safe place, and have it grow until he decided to retire. The bank convinced him that a certain kind of bond was interesting for him.
This kind of bond has a fixed value, and gives a fixed amount of yearly interest, payed to the owner at the end of each year. The bond has no fixed term. Bonds are available in different sizes. The larger ones usually give a better interest. Soon John realized that the optimal set of bonds to buy was not trivial to figure out. Moreover, after a few years his capital would have grown, and the schedule had to be re-evaluated.
Assume the following bonds are available:
Value Annual
interest
4000
3000 400
250
With a capital of e10 000 one could buy two bonds of 4000,givingayearlyinterestof 800. Buying two bonds of 3000,andoneof 4 000 is a better idea, as it gives a yearly interest of 900.Aftertwoyearsthecapitalhasgrownto 11 800, and it makes sense to sell a 3000oneandbuya 4 000 one, so the annual interest grows to 1050.Thisiswherethisstorygrowsunlikely:thebankdoesnotchargeforbuyingandsellingbonds.Nextyearthetotalsumis 12 850, which allows for three times 4000,givingayearlyinterestof 1 200.
Here is your problem: given an amount to begin with, a number of years, and a set of bonds with their values and interests, find out how big the amount may grow in the given period, using the best schedule for buying and selling bonds.
Input
The first line contains a single positive integer N which is the number of test cases. The test cases follow.
The first line of a test case contains two positive integers: the amount to start with (at most 1 000 000), and the number of years the capital may grow (at most 40).
The following line contains a single number: the number d (1 <= d <= 10) of available bonds.
The next d lines each contain the description of a bond. The description of a bond consists of two positive integers: the value of the bond, and the yearly interest for that bond. The value of a bond is always a multiple of $1 000. The interest of a bond is never more than 10% of its value.
Output
For each test case, output – on a separate line – the capital at the end of the period, after an optimal schedule of buying and selling.
Sample Input
1
10000 4
2
4000 400
3000 250
Sample Output
14050

解题思路:
感觉主体部分和做过的01背包差不多,先讨论物品个数,再讨论质量。因为这道题每一年都可以更改投资方案,所以相当于每一年都要根据新的本金进行一次新的dp。所以注意每一年dp前都要用memset清空dp数组。还有就是这道题bond的价值都是以千为单位的,所以可以直接除1000,本金考虑零头也没有意义,也可以直接除1000。

#include<stdio.h>
#include<memory.h>
int dp[100000];

int main()
{
    int t,m,y,d,va[15],in[15];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&m,&y,&d);
        for(int i=1;i<=d;i++)
        {
            scanf("%d%d",&va[i],&in[i]);
            va[i]/=1000;
        }
        int sum=m,k;
        for(int i=1;i<=y;i++)
        {
            memset(dp,0,sizeof(dp));
            k=sum;
            k/=1000;
            for(int j=1;j<=d;j++)
            {
                for(int l=va[j];l<=k;l++)
                {
                    if(dp[l]>(dp[l-va[j]]+in[j]))
                        dp[l]=dp[l];
                    else
                        dp[l]=dp[l-va[j]]+in[j];
                }
            }
            sum+=dp[k];
        }
        printf("%d\n",sum);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值