//水题//花式输出//picture

Give you the width and height of the rectangle,darw it.
Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.
Sample Input
3 2
Sample Output
+—+
| |
| |
+—+

解题思路:
不要畏惧输出空格,把它当成普通字符来看就行了。
遍历的过程中,有的地方输出+,有的地方输出-,有的地方输出|,有的地方输出空格。这么想就不会一看到空格就瑟缩了。

#include<stdio.h>

int main()
{
    int w,h,i,j;
    while(scanf("%d%d",&w,&h)!=EOF)
    {
        w+=2;
        h+=2;
        for(i=1;i<=h;i++)
        {
            for(int j=1;j<=w;j++)
            {
                if(i==1||i==h)
                {
                    if(j==1||j==w)
                        printf("+");
                    else
                        printf("-");
                }
                else
                {
                    if(j==1||j==w)
                        printf("|");
                    else
                        printf(" ");
                }
            }
            printf("\n");
        }
        printf("\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值