hdu 2822 Dogs(BFS + 优先队列)

Dogs

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1909    Accepted Submission(s): 740


Problem Description
Prairie dog comes again! Someday one little prairie dog Tim wants to visit one of his friends on the farmland, but he is as lazy as his friend (who required Tim to come to his place instead of going to Tim's), So he turn to you for help to point out how could him dig as less as he could.

We know the farmland is divided into a grid, and some of the lattices form houses, where many little dogs live in. If the lattices connect to each other in any case, they belong to the same house. Then the little Tim start from his home located at (x0, y0) aim at his friend's home ( x1, y1 ). During the journey, he must walk through a lot of lattices, when in a house he can just walk through without digging, but he must dig some distance to reach another house. The farmland will be as big as 1000 * 1000, and the up left corner is labeled as ( 1, 1 ).
 

Input
The input is divided into blocks. The first line in each block contains two integers: the length m of the farmland, the width n of the farmland (m, n ≤ 1000). The next lines contain m rows and each row have n letters, with 'X' stands for the lattices of house, and '.' stands for the empty land. The following two lines is the start and end places' coordinates, we guarantee that they are located at 'X'. There will be a blank line between every test case. The block where both two numbers in the first line are equal to zero denotes the end of the input.
 

Output
For each case you should just output a line which contains only one integer, which is the number of minimal lattices Tim must dig.
 

Sample Input
  
  
6 6 ..X... XXX.X. ....X. X..... X..... X.X... 3 5 6 3 0 0
 

Sample Output
  
  
3
Hint
Hint: Three lattices Tim should dig: ( 2, 4 ), ( 3, 1 ), ( 6, 2 ).
 

Source
2009 Multi-University Training Contest 1 - Host by TJU

题意是给定起点和终点,在一个矩阵图,经过X没有花费,经过.花费1,求起点到终点的最小花费。
自己用普通的BFS没有写明白,参考了大神的优先队列。
代码:
#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
struct node
{
     int x, y,step;
     node(int _x=0,int _y=0,int _step=0):x(_x),y(_y),step(_step){};
     friend bool operator< (node a, node b)
    {
       return a.step > b.step ;
    }
};
int dir[4][2]={1,0,0,1,-1,0,0,-1};
int n,m;
int sx,sy,ex,ey;
const int maxn=1005;
char mp[maxn][maxn];
int vis[maxn][maxn];
int ans;
int bfs()
{
    priority_queue<node>q;
    node now,next;
    while(!q.empty())
       q.pop();
    q.push(node(sx,sy,0));
    vis[sx][sy]=1;
    while(!q.empty())
    {
        now=q.top();
        q.pop();
        if(now.x==ex&&now.y==ey)
            return now.step;
        for(int i=0;i<4;i++)
        {
            next.x=now.x+dir[i][0];
            next.y=now.y+dir[i][1];
            next.step=now.step;
            if(next.x>=1&&next.x<=m&&next.y>=1&&next.y<=n&&!vis[next.x][next.y])
            {
                if(mp[next.x][next.y]=='.')
                    next.step=now.step+1;
                vis[next.x][next.y]=1;
                q.push(node(next.x,next.y,next.step));
            }
        }
    }
    return -1;
}
int main()
{
    //freopen("in.txt","r",stdin);
    while(scanf("%d %d",&m,&n)!=EOF)
    {
        if(m==0&&n==0)  break;
        memset(vis,0,sizeof(vis));
        for(int i=1;i<=m;i++)
            scanf("%s",mp[i]+1);
        scanf("%d %d %d %d",&sx,&sy,&ex,&ey);
        ans=bfs();
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
对于HDU4546问题,还可以使用优先队列(Priority Queue)来解决。以下是使用优先队列的解法思路: 1. 首先,将数组a进行排序,以便后续处理。 2. 创建一个优先队列(最小堆),用于存储组合之和的候选值。 3. 初始化优先队列,将初始情况(即前0个数的组合之和)加入队列。 4. 开始从1到n遍历数组a的元素,对于每个元素a[i],将当前队列中的所有候选值取出,分别加上a[i],然后再将加和的结果作为新的候选值加入队列。 5. 重复步骤4直到遍历完所有元素。 6. 当队列的大小超过k时,将队列中的最小值弹出。 7. 最后,队列中的所有候选值之和即为前k小的组合之和。 以下是使用优先队列解决HDU4546问题的代码示例: ```cpp #include <iostream> #include <vector> #include <queue> #include <functional> using namespace std; int main() { int n, k; cin >> n >> k; vector<int> a(n); for (int i = 0; i < n; i++) { cin >> a[i]; } sort(a.begin(), a.end()); // 对数组a进行排序 priority_queue<long long, vector<long long>, greater<long long>> pq; // 最小堆 pq.push(0); // 初始情况,前0个数的组合之和为0 for (int i = 0; i < n; i++) { long long num = pq.top(); // 取出当前队列中的最小值 pq.pop(); for (int j = i + 1; j <= n; j++) { pq.push(num + a[i]); // 将所有加和结果作为新的候选值加入队列 num += a[i]; } if (pq.size() > k) { pq.pop(); // 当队列大小超过k时,弹出最小值 } } long long sum = 0; while (!pq.empty()) { sum += pq.top(); // 求队列中所有候选值之和 pq.pop(); } cout << sum << endl; return 0; } ``` 使用优先队列的方法可以有效地找到前k小的组合之和,时间复杂度为O(nklog(k))。希望这个解法对你有所帮助!
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值