hdu 1496 Equations

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1496


Problem Description
Consider equations having the following form:

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.
 

Input
The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.
 

Output
For each test case, output a single line containing the number of the solutions.
 

Sample Input
  
  
1 2 3 -4 1 1 1 1
 

Sample Output
  
  
39088 0
 
暴力求解,先把1~100以内的平方表打出来,然后是对方程进行变形

                a*x1^2+b*x2^2+c*x3^2+d*x4^2=0

变形为      a*x1^2+b*x2^2+c*x3^2=-d*x4^2,求出左边的式子,然后枚举出x4的解是否存在于1~100的平方数里。最后把结果乘以16,因为四个变量都可以取正负。

代码:

#include<stdio.h>
#include<string.h>
int main()
{
    int a,b,c,d;
    int num[110];
    for(int i=1;i<=100;i++)
        num[i]=i*i;
    while(scanf("%d %d %d %d",&a,&b,&c,&d)!=EOF)
    {
        if(a>0&&b>0&&c>0&&d>0||a<0&&b<0&&c<0&&d<0)
        {
            printf("0\n");
            continue;
        }
        int t1=0,t2=0;
        int ans=0;
        for(int i=1;i<=100;i++)
        {
            for(int j=1;j<=100;j++)
            {
                t1=a*num[i]+b*num[j];

                for(int k=1;k<=100;k++)
                {
                    t2=t1+c*num[k];
                    if(t2%d==0)
                    {
                        t2/=-d;
                        if(t2>0)
                        {
                            for(int l=1;l<=100;l++)
                                if(t2==num[l])
                            {
                                ans++;
                                break;
                            }
                        }
                    }
                }
            }
        }
        printf("%d\n",ans*16);
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值