hdu 1894 String Compare

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1894

Problem Description
Maybe there are 750,000 words in English and some words are prefix of other words, for example: the word "acm" can be treat as one prefix of "acmicpc". What's more, most of such pairs of words have relationship between them. Now give you a dictionary, your work is to tell me how many such pairs.


There may be other characters in the word, for example '_','-',and so on.
Pay attention that 'A' and 'a' are not the same character!
 

Input
In the first line of the input file there is an Integer T, which means the number of test cases. Followed by T test cases.
For each test case, in the first line there is an integer N(0<N<=50000), followed N lines, each contains a word whose length is less than 30 and no space appears in any word. There are no same words in two different lines.
 

Output
For each test case, tell me how many such pairs. If the number is larger than 11519, just divide it by 11519 and only output the remainder.
 

Sample Input
  
  
2 2 acmicpc acm 3 a abc ab
 

Sample Output
  
  
1 3
 

Author
Sempr|CrazyBird|hust07p43
 

Source
 

题意是求给定的串中有几对包含相同的前缀。。。刚开始自己以为要用字典树写,后来一个学姐告诉我可以暴力枚举。。

代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<string>
#include<math.h>
#include<stdlib.h>
#include<map>
#include<stack>
#include<queue>
#include<set>
#include<vector>
#define max(x,y)x>y?x:y
#define min(x,y)x<y?x:y
#define swap(a,b) a=a^b,b=a^b,a=a^b
using namespace std;
const int maxn=50005;
typedef struct
{
    char s[40];
}node;
node ss[maxn];
bool cmp(node a,node b)
{
    return strcmp(a.s,b.s)<0;
}
int main()
{
    //freopen("in.txt","r",stdin);
     int t;
    scanf("%d",&t);
    while(t--)
    {
        int cnt=0;
        int n;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%s",ss[i].s);
        sort(ss,ss+n,cmp);
        for(int i=0;i<n;i++)
        {
            int len=strlen(ss[i].s);
            for(int j=i+1;j<n;j++)
            {
                int ok=1;
                for(int k=0;k<len;k++)
                {
                    if(ss[i].s[k]!=ss[j].s[k])
                        {
                            ok=0;
                            break;
                        }
                }
                if(ok)
                    cnt++;
                else
                    break;
            }
        }
        if(cnt>11519)
            printf("%d\n",cnt%11519);
        else
            printf("%d\n",cnt);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值