hdu 2119 Matrix(二分最大匹配)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2119

Problem Description
Give you a matrix(only contains 0 or 1),every time you can select a row or a column and delete all the '1' in this row or this column .

Your task is to give out the minimum times of deleting all the '1' in the matrix.
 

Input
There are several test cases.

The first line contains two integers n,m(1<=n,m<=100), n is the number of rows of the given matrix and m is the number of columns of the given matrix.
The next n lines describe the matrix:each line contains m integer, which may be either ‘1’ or ‘0’.

n=0 indicate the end of input.
 

Output
For each of the test cases, in the order given in the input, print one line containing the minimum times of deleting all the '1' in the matrix.
 

Sample Input
  
  
3 3 0 0 0 1 0 1 0 1 0 0
 

Sample Output
  
  
2
 

Author
Wendell
 

Source


题意,给你一个0、1矩阵,每次可以消去一行或者一列的1,问最少的次数消去所有的1。以行和列为左右集,建二分图,然后求二分最大匹配。

代码:

#include<stdio.h>
#include<string.h>
const int maxn=110;
int mp[maxn][maxn];
int vis[maxn];
int nx,ny,cx[maxn],cy[maxn];
int n,m;
int find(int u)
{
    for(int i=1;i<=ny;i++)
    {
        if(mp[u][i]&&!vis[i])
        {
            vis[i]=1;
            if(cy[i]==-1||find(cy[i]))
            {
                cy[i]=u;
                cx[u]=i;
                return 1;
            }
        }
    }
    return 0;
}
void match()
{
    int res=0;
    memset(cy,-1,sizeof(cy));
    memset(cx,-1,sizeof(cx));
    for(int i=1;i<=nx;i++)
    {
        if(cx[i]==-1)
        {
            memset(vis,0,sizeof(vis));
            res+=find(i);
        }
    }
    printf("%d\n",res);
}
int main()
{
    //freopen("in.txt","r",stdin);
    while(scanf("%d",&n)&&n)
    {
        scanf("%d",&m);
        memset(mp,0,sizeof(mp));
        nx=n;
        ny=m;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                int num;
                scanf("%d",&num);
                if(num)
                    mp[i][j]=1;
            }
        }
        match();
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值