POJ-2488 A Knight's Journey(dfs+记录路径+字典序处理)

题目链接https://vjudge.net/contest/357631#problem/D
Description
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

翻译
给出一个p行q列的国际棋盘,马可以从任意一个格子开始走,问马能否不重复的走完所有的棋盘。
如果可以,输出按字典序排列最小的路径
打印路径时,列用大写字母表示(A表示第一列),行用阿拉伯数字表示(从1开始),先输出列,再输出行。

分析

  1. 如何按字典序最小的顺序输出?

从(1,1)开始,按如下步骤,即可保证字典序最小。对方向数组进行操作

int to[8][2]= {-1,-2,1,-2,-2,-1,2,-1,-2,1,2,1,-1,2,1,2};

在这里插入图片描述

  1. 如何记录路径?

一共p * q个点,结束条件是搜的点数等于p*q。开一个二维数组,记录搜到的每个点的x和y的坐标。

代码

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int p,q;
int mp[50][3],book[50][50],flag;
int to[8][2]= {-1,-2,1,-2,-2,-1,2,-1,-2,1,2,1,-1,2,1,2};
void dfs(int x,int y,int sum)
{
    mp[sum][0]=y;
    mp[sum][1]=x;
    if(sum==p*q)
    {
        flag=1;
        return;
    }
    for(int i=0; i<8; i++)
    {
        int tx=x+to[i][0];
        int ty=y+to[i][1];
        if(tx>=1&&tx<=p&&ty>=1&&ty<=q&&book[tx][ty]==0&&flag==0)/*已经初始化方向数组,若搜到的点数等于p*q,那么这一定是字典序最小的路径,直接返回即可,flag==0的条件非常重要,防止返回时别的路径的影响*/
        {
            book[tx][ty]=1;
            dfs(tx,ty,sum+1);
            book[tx][ty]=0;
        }
    }
}
int main()
{
    int t,tt=1;
    scanf("%d",&t);
    while(t--)
    {
        flag=0;
        memset(book,0,sizeof(book));
        memset(mp,0,sizeof(mp));
        scanf("%d%d",&p,&q);
        book[1][1]=1;
        dfs(1,1,1);
        printf("Scenario #%d:\n",tt++);
        if(!flag)
            printf("impossible\n");
        else
        {
            for(int i=1; i<=p*q; i++)
                printf("%c%d",mp[i][0]-1+'A',mp[i][1]);
            printf("\n");
        }
        if(t!=0)
            printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zaiyang遇见

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值