POJ2299 Ultra-QuickSort(归并排序)

题目链接https://vjudge.net/contest/369436#problem/F
In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.
Input
The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 – the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.
Output
For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.
Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

翻译
通过交换两个相邻的元素来处理n个不同的整数序列,直到序列按升序排序。问最少需要多少次操作?

归并排序思想:
假设初始序列含有n个记录,首先将这n个记录看成n个有序的子序列,每个子序列的长度为1,然后两两归并,得到[n/2]个长度为2(n为奇数时,最后一个序列的长度为1)的有序子序列。

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=5*1e5+10;
typedef long long LL;
LL a[N],res,r[N];
void Merge(int low,int mid,int high)
{
    int i,j,k;
    i=low,j=mid+1,k=low;
    while((i<=mid)&&(j<=high))
    {
        if(a[i]<=a[j])
            r[k++]=a[i++];
        else
        {
            r[k++]=a[j++];
            res+=j-k;
        }
    }
    while(i<=mid)///其中一个没用完
        r[k++]=a[i++];
    while(j<=high)
        r[k++]=a[j++];
    for(int i=low; i<=high; i++)
        a[i]=r[i];
}
void Mergesort(int low,int high)
{
    int mid;
    if(low==high)
        return;
    else
    {
        mid=(low+high)/2;
        Mergesort(low,mid);///左部分,右部分
        Mergesort(mid+1,high);
        Merge(low,mid,high);
    }
}
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        for(int i=0; i<n; i++)
            scanf("%lld",&a[i]);
        res=0;
        Mergesort(0,n-1);///对数组a做归并排序
        printf("%I64d\n",res);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zaiyang遇见

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值