POJ - 1459 Power Network(最大流EK算法)

题目链接https://vjudge.net/contest/369436#problem/C
A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l max(u,v) of power delivered by u to v. Let Con=Σ uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con.
在这里插入图片描述
An example is in figure 1. The label x/y of power station u shows that p(u)=x and p max(u)=y. The label x/y of consumer u shows that c(u)=x and c max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6.
Input
There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.
Output
For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.
Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6

翻译
N个点(可能为发电站、消耗站或调度站)
NP个发电站供电,NC个消耗站耗电,调度站不供电,不耗电。
M条单向路径:(U,V)Z:从U到V传输的最大功率为Z。

先给出M条单向线路的(U,V)Z,表示站U到站V传输的最大功率是Z;
再给出NP个发电站的(U)Z,表示发电站U提供的最大功率是Z;
最后给出NC个消耗站的(U)Z,表示消耗站U消耗的最大功率是Z。
求这个网络能够消耗的最大功率。

分析
增加一个超级源点0,用于将发电站提供的电表示为发电站从超级源点得到电,即超级源点到发电站传输的最大功率是发电站U提供的最大功率
增加一个超级汇点N+1,用于将消耗站消耗的电表示为消耗站向超级汇点输出电,即消耗站到超级汇点传输的最大功率是消耗站U消耗的最大功率

求从0到n+1传输的最大功率

-----------------------------------------------------------------------

FF和EK的不同:
FF每次找的不是最短增广路径,找路径是随机的;EK每次找的增广路径是通过bfs找的是最短的。

-----------------------------------------------------------------------

代码

#include<cstdio>
#include<cstring>
#include<math.h>
#include<iostream>
#include<queue>
#include<stdlib.h>
#include<algorithm>
using namespace std;
const int INF=0x3f3f3f3f;
const int N=1e2+10;
int capacity[N][N];
int flow[N];///从源点到当前结点最大还能多少流量
int pre[N];///记录路径
bool book[N];
int n,np,nc,m;
void init()
{
    memset(capacity,0,sizeof(capacity));
    memset(flow,0,sizeof(flow));
}
int bfs(int source,int focal)
{
    memset(pre,-1,sizeof(pre));
    memset(book,false,sizeof(book));
    queue<int>Q;
    book[source]=true;
    flow[source]=INF;
    pre[source]=0;
    Q.push(source);
    while(!Q.empty())
    {
        int index=Q.front();
        Q.pop();
        if(index==focal)
            break;
        for(int i=0; i<=n+1; i++)
        {
            if(!book[i]&&capacity[index][i]>0)
            {
                pre[i]=index;
                book[i]=true;
                flow[i]=min(flow[index],capacity[index][i]);
                Q.push(i);
            }
        }
    }
    if(pre[focal]==-1)
        return -1;
    else
        return flow[focal];

}
int max_flow(int source,int focal)
{
    int sum_flow=0;
    while(1)
    {
        int flag=bfs(source,focal);///找一条最短的增广路径
        if(flag==-1)
            return sum_flow;
        else
        {
            for(int i=focal; i!=source; i=pre[i])
            {
                capacity[pre[i]][i]-=flag;
                capacity[i][pre[i]]+=flag;
            }
            sum_flow+=flag;
        }
    }
    return sum_flow;
}
int main()
{
    while(~scanf("%d%d%d%d",&n,&np,&nc,&m))
    {
        char ch;
        int u,v,z;
        init();
        while(m--)
        {
            cin>>ch>>u>>ch>>v>>ch>>z;
            u++,v++;///0结点空出来
            capacity[u][v]+=z;
        }
        while(np--)///np个发电站
        {
            cin>>ch>>v>>ch>>z;
            ++v;
            capacity[0][v]+=z;
        }
        while(nc--)///nc个消耗站
        {
            cin>>ch>>u>>ch>>z;
            ++u;
            capacity[u][n+1]=z;
        }
        cout<<max_flow(0,n+1)<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zaiyang遇见

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值