POJ - 2955 Brackets(区间dp)

题目链接https://vjudge.net/contest/372515#problem/E
We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].
Input
The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output
For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.
Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

翻译
给出一个字符串,求能够匹配的字符有多少对?
结果输出对数乘以2

区间dp的一般固定解法
枚举区间长度,再枚举左端点,之后枚举区间的断点进行转移。

代码

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=1e2+10;
int dp[N][N];///dp[i][j]:区间[i,j]内能够匹配的字符的个数
char mp[N];
int main()
{
    while(~scanf("%s",mp))
    {
        if(mp[0]=='e')
            break;
        memset(dp,0,sizeof(dp));
        int len=strlen(mp);
        for(int i=1; i<len; i++)
        {
            for(int j=0,k=i; k<len; j++,k++)///i和j的循环枚举所有的区间:长度为1的,长度为2的,,,
            {
                if(mp[j]=='('&&mp[k]==')'||mp[j]=='['&&mp[k]==']')
                    dp[j][k]=dp[j+1][k-1]+2;
                for(int m=j; m<k; m++)///枚举断点
                    dp[j][k]=max(dp[j][k],dp[j][m]+dp[m+1][k]);
            }
        }
        printf("%d\n",dp[0][len-1]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zaiyang遇见

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值