POJ - 1651 Multiplication Puzzle(区间dp)

题目描述:https://vjudge.net/contest/374535#problem/E
The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring
10 ∗ 1 ∗ 50 + 50 ∗ 20 ∗ 5 + 10 ∗ 50 ∗ 5 = 500 + 5000 + 2500 = 8000 10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000 10150+50205+10505=500+5000+2500=8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be
1 ∗ 50 ∗ 20 + 1 ∗ 20 ∗ 5 + 10 ∗ 1 ∗ 5 = 1000 + 100 + 50 = 1150. 1 * 50 * 20 + 1 * 20 * 5 + 10 * 1*5 = 1000+100+50 = 1150. 15020+1205+1015=1000+100+50=1150.
Input
The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.
Output
Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650

翻译:
有n个数字排成一行,按一定次序从中拿走n-2个数字(第1个和最后1个数字不能拿),每次只拿一个,取走数字的同时,会得到一个分数。
分数的计算方法是:要拿走的数字,和它左右两边的数字,这3个数字的乘积
按不同的顺序取走n-2个数字,得到的总分可能不相同,求出给定一组数字按上述规则拿取的最小得分

分析:
d p [ i , j ] dp[i,j] dp[i,j]:区间[i,j],假设有m个数,删除m-2个数的最小价值

区间dp最核心的两层for枚举所有的区间,第三层for循环枚举断点

完整代码:

#include<cstdio>
#include<cstring>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
typedef long long LL;
const int N=1e2+10;
const int inf=0x3f3f3f3f;
LL dp[N][N];
int a[N],n;
int main()
{
    scanf("%d",&n);
    for(int i=1; i<=n; i++)
        scanf("%d",&a[i]);
    memset(dp,0,sizeof(dp));
    for(int i=2; i<=n; i++)
    {
        for(int j=1; j+i<=n; j++) ///因为不能删除两端的数,所以区间长度最短为2
        {
            dp[j][j+i]=inf;
            for(int k=j+1; k<j+i; k++)
                dp[j][j+i]=min(dp[j][j+i],(LL)dp[j][k]+dp[k][j+i]+a[j]*a[k]*a[j+i]);
        }
    }
    printf("%lld\n",dp[1][n]);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zaiyang遇见

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值