总理戒指(素数圆环)

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

在这里插入图片描述

Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

题意分析:每一行样例围成一个环,相邻数字的和应该是素数
解题思路:从第一数开始搜索,如果下一个数和这个数的和为素数,则把这个数放入下一个数,如果到了最后一个数,而且最后一个数和第一个数的和也为素数,则为搜索出口,

实现代码:

#include<stdio.h>
#include<math.h>
#include<string.h>
int a[10100],fact[100],n;
int Isprime(int n)
{
	int k;
	k=sqrt(n);
	if(n==1) return 0;
	for(int i=2;i<=k;i++)
	{
		if(n%i==0)
		return 0;
	}
	return 1;
}
void dfs(int num)//深搜
{
	if(num==n&&Isprime(a[0]+a[num-1])==1&&n>1)//出口
	{
		printf("%d",a[0]);
		for(int i=1;i<n;i++)
		printf(" %d",a[i]);
		printf("\n");
	}
	for(int i=2;i<=n;i++)
	{
		if(Isprime(i+a[num-1])==1&&fact[i]!=1)
		{
			a[num]=i;
			num++;
			fact[i]=1;//标记用过的数
			dfs(num);//再次深搜
			fact[i]=0;//解除标记,
			num--;
		}
	}
}
int main()
{
	int id=1;
	while(scanf("%d",&n)!=EOF)
	{
		memset(fact,0,sizeof(fact));
		printf("Case %d:\n",id++);
		a[0]=1;
		dfs(1);
		printf("\n");
	}
}
  • 3
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值