每日一题(二十八):Prime ring problem

问题描述:

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.


输入:
n (1 < n < 17).
输出:
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in
lexicographical order.You are to write a program that completes above process.Print a blank line after each case.

样例输入:
6
8
样例输出:
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

#include<stdio.h>
#include<string.h>

int ans[22];  //保存环中每一个被放入的数
bool hash[22];//标记已经放入环中的数
int n;
int prime[] = { 2,3,5,7,11,13,17,19,23,29,31,37,41 };
bool judge(int x) {
	for (int i = 0; i < 13; i++) {
		if (prime[i] == x)
			return true;
	}
	return false;
}
void check() {  //检查输出由回溯法枚举得到的解
	if (judge(ans[n] + ans[1]) == false)
		return;
	for (int i = 1; i <= n; i++) {
		if (i != 1)
			printf(" ");
		printf("%d", ans[i]);
	}
	printf("\n");
}
void DFS(int num) { //递归枚举,num为当前已放入环中的数字
	if (num > 1)
		if (judge(ans[num] + ans[num - 1]) == false)
			return;
	if (num == n) {
		check();
		return;
	}
	for (int i = 2; i <= n; i++) {
		if (hash[i] == false) {//若i还没有被放入环中
			hash[i] = true;    //标记i为已经使用
			ans[num + 1] = i;  //把这个数字放入下一个数
			DFS(num + 1);      //继续尝试下一个数
			hash[i] = false;   //回溯时,将i重新标记为未使用
		}
	}
}
int main() {
	int cas = 0;
	while (scanf("%d", &n) != EOF) {
		cas++;
		for (int i = 0; i < 22; i++)
			hash[i] = false;
		ans[1] = 1;
		printf("Case %d:\n", cas);
		hash[1] = true;
		DFS(1);
		printf("\n");
	}
	return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值