1053. Path of Equal Weight (30)


时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.


Figure 1

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1, A2, ..., An} is said to be greater than sequence {B1, B2, ..., Bm} if there exists 1 <= k < min{n, m} such that Ai = Bi for i=1, ... k, and Ak+1 > Bk+1.

Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

n为结点数,m为非叶子结点数,S为权重数。

n个结点的权重。

m行父节点和子节点的关系。


如果从根节点到叶子结点的权重和为S,则从大到小输出。


参照算法笔记P304.

1.输入时,对所有子节点的权重从大到小排序,dfs时的输出顺序就是从大到小。

2.好好背dfs模板。


结构体中保存子节点 vector<int>child


#include<stdio.h>
#include<vector>
#include<algorithm>
using namespace std;
int S;
vector<int>path;
struct node{
	int id;
	int weight;
	vector<int>child;
}stu[110];
bool comp(int a,int b){
	return stu[a].weight>stu[b].weight;
}
void dfs(int s){
	if(stu[s].child.size()==0){
		path.push_back(s);
		int dis=0,i;
		for(i=path.size()-1;i>=0;i--){
			dis=dis+stu[path[i]].weight;
		}
		if(dis==S){
			printf("%d",stu[path[0]].weight);
			for(i=1;i<path.size();i++){
				printf(" %d",stu[path[i]].weight);
			}
			printf("\n");
		}
		path.pop_back();
		return;
	}
	path.push_back(s);
	int i;
	for(i=0;i<stu[s].child.size();i++){
		dfs(stu[s].child[i]);
	}
	path.pop_back();
}
int main(){
	int n,m,i,j,id,k,tempid;
	scanf("%d %d %d",&n,&m,&S);
	for(i=0;i<n;i++){
		scanf("%d",&stu[i].weight);
		stu[i].id=i;
	}
	for(i=0;i<m;i++){
		scanf("%d %d",&id,&k);
		for(j=0;j<k;j++){
			scanf("%d",&tempid);
			stu[id].child.push_back(tempid);
		}
		sort(stu[id].child.begin(),stu[id].child.end(),comp);
	}
	dfs(0);
} 



#include<stdio.h>
#include<vector>
#include<algorithm>
using namespace std;
int n,m,s;
struct node{
	int weight;
	vector<int>child;
}tree[110];
//bool comp(int a,int b){
//	return a>b;
//}
bool comp(int a,int b){
	return tree[a].weight>tree[b].weight;
}
vector<int>path;
void dfs(int root,int sum){
	path.push_back(root);
	if(sum>s){
		path.pop_back();
		return;
	}
	if(tree[root].child.size()==0&&sum==s){
		int i;
		for(i=0;i<path.size();i++){
			printf("%d",tree[path[i]].weight);
			if(i!=path.size()-1){
				printf(" ");
			}
		}
		printf("\n");
		path.pop_back();
		return;
	}
	int i;
	for(i=0;i<tree[root].child.size();i++){
		int next=tree[root].child[i];
		dfs(next,sum+tree[next].weight);
	}
	path.pop_back();//!!!!!!!
}
int main(){
	int i,j,k,weight,father,child;
	scanf("%d %d %d",&n,&m,&s);
	for(i=0;i<n;i++){
		scanf("%d",&tree[i].weight);
	}
	for(i=0;i<m;i++){
		scanf("%d %d",&father,&k);
		for(j=0;j<k;j++){
			scanf("%d",&child);
			tree[father].child.push_back(child);
		}
		sort(tree[father].child.begin(),tree[father].child.end(),comp);
	}
	dfs(0,tree[0].weight);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值