【PAT 1053】 Path of Equal Weight 深度优先搜索

1053. Path of Equal Weight (30)

时间限制
10 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.


Figure 1

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1, A2, ..., An} is said to be greater than sequence {B1, B2, ..., Bm} if there exists 1 <= k < min{n, m} such that Ai = Bifor i=1, ... k, and Ak+1 > Bk+1.

Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2


题意:

从给出的多叉树中,找到从根到叶的某一权值总和的路径,并根据节点权值从大到小输出。

分析:

使用Dijkstra算法,发现几条路径求出来以后,很难进行排序输出;

使用深度优先搜索,在搜索前根据权值进行从大到小排序,这样便保证了搜索的匹配结果顺序就是可直接输出的顺序。

代码:

#include <iostream>
#include <fstream>
#include <algorithm>
#include <stack>
#include <vector>
#include <queue>
#include <cstdio>
#include <cstring>
#include <memory>
using namespace std;

//此代码使用前,需删除下面两行+后面的system("PAUSE")
ifstream fin("in.txt");
#define cin fin

int weight[101]={0};
int parent[101]={0};
int childNum[101]={0};
int sum[101]={0};
int linkNode[101][101]={0};

void print(int pa){			//根据叶节点回溯打印链表
	stack<int> st;
	while(pa != -1){
		st.push(weight[pa]);
		pa = parent[pa];
	}
	cout<<st.top();
	st.pop();
	while(!st.empty()){
		cout<<' '<<st.top();
		st.pop();			
	}
	cout<<endl;
}

void DFS(int cur,int s){			//深度优先搜索
	int next;
	for(int i=0;i<childNum[cur];i++){
		next = linkNode[cur][i];
		sum[next] = sum[cur]+weight[next];
		if(sum[next]==s){				//如果权值和等于目标值
			if(childNum[next]==0){		//又恰好是叶节点,则输出
				print(next);
			}else{			//不是叶节点,则跳出循环
				continue;
			}
		}else if(sum[next]<s){		//权值和小于目标,继续深度搜索
			DFS(next,s);
		}else{					//权值和大于目标,没必要继续深搜该节点
			continue;
		}

	}
}

bool cmp(const int& aa,const int& bb){
	return weight[aa] > weight[bb];
}

int main()
{
	int n,m,s;
	scanf("%d %d %d",&n,&m,&s);
	int i,j;
	for(i=0;i<n;i++)scanf("%d",&weight[i]);
	int nonleaf,num,leaf;
	parent[0] = -1;
	for(i=0;i<m;i++){
		scanf("%d %d",&nonleaf,&num);
		childNum[nonleaf] = num;
		for(j=0;j<num;j++){
			scanf("%d",&leaf);
			linkNode[nonleaf][j] = leaf;
			parent[leaf]=nonleaf;
		}
		sort(linkNode[nonleaf],linkNode[nonleaf]+num,cmp);		//把每个节点的所有子节点从大到小排序
	}
	if(m==0){			//当仅有一个根节点时
		if(weight[0]==s)cout<<weight[0]<<endl;
		return 0;
	}
	memcpy(sum,weight,n*sizeof(int));		//拷贝权重到sum数组
	DFS(0,s);
	system( "PAUSE");
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值