1127. ZigZagging on a Tree (30)

1127. ZigZagging on a Tree (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
Sample Output:
1 11 5 8 17 12 20 15

建树,分奇偶输出即可


#include<stdio.h>
#include<stdlib.h>
#include<queue>
#include<vector>
using namespace std;
typedef struct Node *node;
struct Node{
	int x;
	int depth;
	node left;
	node right;
};
int in[35],post[35];
vector<int>level[35];
node build(int s1,int e1,int s2,int e2){
	node T=(node)malloc(sizeof(struct Node));
	T->x=post[e2];
	T->left=T->right=NULL;
	int i,root;
	for(i=s1;i<=e1;i++){
		if(in[i]==post[e2]){
			root=i;break;
		}
	}
	if(root!=s1){
		T->left=build(s1,root-1,s2,root-1-s1+s2);
	}
	if(root!=e1){
		T->right=build(root+1,e1,root-1-s1+s2+1,e2-1);
	}
	return T;
}
int main(){
	int n,i,j;
	scanf("%d",&n);
	for(i=0;i<n;i++){
		scanf("%d",&in[i]);
	}
	for(i=0;i<n;i++){
		scanf("%d",&post[i]);
	}
	node T=build(0,n-1,0,n-1);
	queue<node>q;
	T->depth=1;
	q.push(T);
	int deepest=0;
	while(!q.empty()){
		node head=q.front();
		q.pop();
		if(head->depth>deepest){
			deepest=head->depth;
		}
		level[head->depth].push_back(head->x);
		if(head->left){
			head->left->depth=head->depth+1;
			q.push(head->left);
		}
		if(head->right){
			head->right->depth=head->depth+1;
			q.push(head->right);
		}
	}
	printf("%d",T->x);
	for(i=2;i<=deepest;i++){
		if(i%2==0){
			for(j=0;j<level[i].size();j++){
				printf(" %d",level[i][j]);
			}
		}
		else{
			for(j=level[i].size()-1;j>=0;j--){
				printf(" %d",level[i][j]);
			}
		}
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值