1109. Group Photo (25)

1109. Group Photo (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Formation is very important when taking a group photo. Given the rules of forming K rows with N people as the following:

  • The number of people in each row must be N/K (round down to the nearest integer), with all the extra people (if any) standing in the last row;
  • All the people in the rear row must be no shorter than anyone standing in the front rows;
  • In each row, the tallest one stands at the central position (which is defined to be the position (m/2+1), where m is the total number of people in that row, and the division result must be rounded down to the nearest integer);
  • In each row, other people must enter the row in non-increasing order of their heights, alternately taking their positions first to the right and then to the left of the tallest one (For example, given five people with their heights 190, 188, 186, 175, and 170, the final formation would be 175, 188, 190, 186, and 170. Here we assume that you are facing the group so your left-hand side is the right-hand side of the one at the central position.);
  • When there are many people having the same height, they must be ordered in alphabetical (increasing) order of their names, and it is guaranteed that there is no duplication of names.

Now given the information of a group of people, you are supposed to write a program to output their formation.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers N (<=10000), the total number of people, and K (<=10), the total number of rows. Then N lines follow, each gives the name of a person (no more than 8 English letters without space) and his/her height (an integer in [30, 300]).

Output Specification:

For each case, print the formation -- that is, print the names of people in K lines. The names must be separated by exactly one space, but there must be no extra space at the end of each line. Note: since you are facing the group, people in the rear rows must be printed above the people in the front rows.

Sample Input:
10 3
Tom 188
Mike 170
Eva 168
Tim 160
Joe 190
Ann 168
Bob 175
Nick 186
Amy 160
John 159
Sample Output:
Bob Tom Joe Nick
Ann Mike Eva
Tim Amy John

以前刷乙级的时候写的,有空来优化,


#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct Node{
	char name[9];//名字 
	int height;//身高 
};
//身高从小到大,如果相同,则按名字的字典序升序排列 
int Comp(const void*p1,const void*p2)
{
	struct Node*c=(struct Node*)p1;
	struct Node*d=(struct Node*)p2;
	if(c->height!=d->height) return c->height-d->height;
	else return strcmp((*(struct Node*)p2).name,(*(struct Node*)p1).name);
}
int main(){
	int n,K,i,j,k;
	scanf("%d %d",&n,&K);
	struct Node stu[n];
	for(i=0;i<n;i++){
		scanf("%s %d",&stu[i].name,&stu[i].height); 
	}
	qsort(stu,n,sizeof(stu[0]),Comp);
	
	int cow=K;
	int col=n/K;//偶数列的时候考虑下 !!! 
	struct Node arr[cow][col];
	int first,temp;
	if(col%2==0){//偶数列最后一行从0  开始!  奇数列最后一行从1开始!! 
		first=0;
	}
	else{
		first=1;
	}
	for(i=cow-1;i>0;i--){//第一行单独考虑 
		temp=first;
		for(j=0;j<col/2;j++){
			arr[i][j]=stu[temp];
			temp=temp+2;
		}
		temp=temp-1;
		int lie;
		if(col%2==0){
			lie=col/2;
		}
		else{
			lie=col/2+1;
		}
		for(k=0;k<lie;j++,k++){
			arr[i][j]=stu[temp];
			temp=temp-2;
		}
		first=first+col;
	}
	int sy=col+n-col*cow;
//	printf("%d\n",sy);
	struct Node stu1[sy];
	if(sy%2==0){
		first=(cow-1)*col;
		temp=first;
		for(i=0;i<sy/2;i++){
			stu1[i]=stu[temp];
			temp=temp+2;
		}
		temp=temp-1;
		for(j=0;j<sy/2;j++,i++){
			stu1[i]=stu[temp];
			temp=temp-2;
		}
	}
	else{
		first=(cow-1)*col+1;
		temp=first;
		for(i=0;i<sy/2;i++){
			stu1[i]=stu[temp];
			temp=temp+2;
		}
		temp=temp-1;
		for(j=0;j<sy/2+1;j++,i++){
			stu1[i]=stu[temp];
			temp=temp-2;
		}
	}
	for(i=0;i<sy;i++){
		if(i!=sy-1){
			printf("%s ",stu1[i].name);
		}
		else{
			printf("%s",stu1[i].name);
		}
	}
	printf("\n");
	
	for(i=1;i<cow;i++){
		for(j=0;j<col;j++){
			if(j==col-1){
				printf("%s",arr[i][j].name);
			}
			else{
				printf("%s ",arr[i][j].name);
			}
		}
		printf("\n");
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
SELECT bs.report_no, bs.sample_id, bs.test_id, bs.service_type, bs.sample_name, bs.total_fee, bs.receivable_fee, bs.sample_no, bs.ranges, bs.grade, bs.sample_remark AS remark, bs.factory, bs.item_name, bs.apply_dept, bs.specification, bs.factory_number, bs.calibrat_point, bs.mandatory_flag, bs.inspection_type, bs.report_org_name, bs.plan_complete_date, bs.standard_instrument_name, bs.bleeding_site_name, bs.arrive_date, DATEDIFF( bs.plan_complete_date, NOW()) AS surplus_days, bs.order_no, bs.order_type, bs.customer_name, bs.order_id, bs.business_type, bs.group_id, bs.group_name, bs.item_id, bs.is_merge, bs.pass_time, bs.audit_time, bs.report_id, bs.compile_time, bs.generate_time, bs.pass_user_name, bs.audit_user_name, bs.compile_user_name, bs.report_state, bs.is_just_certificate, bs.label_price, bs.labor_cost, bs.product_type, bs.batch_number, bs.original_number, bs.type_no, bs.template_id, bs.template_version, bs.standard_instrument_id, bs.standard_instrument_name, bs.report_query_code, bs.test_user_id, bs.test_user_name, bs.test_time, bs.review_user_id, bs.review_user_name, bs.review_time, bs.or_number, bs.test_result, bs.test_result_text, bs.test_date, bs.test_address, bs.result_value, bs.unit, bs.test_dept_id, bs.test_dept_name, bs.sample_mass, bs.form, bs.color, bs.clarity, bs.amplification_detection, bs.precious_metal, bs.remarks, bs.photo, bs.identifying_code, bs.diamond_quality, bs.hand_ring, bs.craft, bs.instrument_photo, bs.customer_item_basis, bs.quality_photo, bs.check_point, bs.check_code, bs.mass_unit, bs.manufacturer_name, bs.manufacturer_addr, bs.result_sample_describe AS sampleDescribe, bs.test_rule AS metalRuleIdsStr, bsa.attach_id FROM view_sample_info bs JOIN bus_sample_report bsr ON bs.report_id = bsr.id JOIN bus_sample sa ON bsr.sample_id = sa.id JOIN bus_sample_attr bsa ON sa.id = bsa.id 需要按照bs.report_no 的整数来从小到大进行排序
最新发布
07-15

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值