1143. Lowest Common Ancestor (30)

1143. Lowest Common Ancestor (30)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (<= 1000), the number of pairs of nodes to be tested; and N (<= 10000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line "LCA of U and V is A." if the LCA is found and A is the key. But if A is one of U and V, print "X is an ancestor of Y." where X is A and Y is the other node. If U or V is not found in the BST, print in a line "ERROR: U is not found." or "ERROR: V is not found." or "ERROR: U and V are not found.".

Sample Input:
6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99
Sample Output:
LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

这题我猜的,猜对了~

当结点的值 大于等于小的,小于等于大的就是答案

#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
typedef struct Node *node;
int c1,c2,ans;
int pre[10010],in[10010];
int cou[9999999];
struct Node{
	int x;
	node left;
	node right;
};
node build(int s1,int e1,int s2,int e2){
	node T=(node)malloc(sizeof(struct Node));
	T->x=pre[s1];
	T->left=T->right=0;
	int root,i;
	for(i=s2;i<=e2;i++){
		if(in[i]==pre[s1]){
			root=i;break;
		}
	}
	if(root!=s2){
		T->left=build(s1+1,root-s2+s1,s2,root-1);
	}
	if(root!=e2){
		T->right=build(root-s2+s1+1,e1,root+1,e2);
	}
	return T;
}
void dfs(node T){//这个我猜的...结果猜对了... 
	if(T){
		if(T->x>=c1&&T->x<=c2){//当结点的值 大于等于小的,小于等于大的就是答案(猜对了= =) 
			ans=T->x;return;
		}
		else if(T->x>=c2){
			dfs(T->left);
		}
		else if(T->x<=c1){
			dfs(T->right);
		}		
	}
}
int main(){
	int n,m,i,flag1,flag2,tmp;
	scanf("%d %d",&m,&n);
	for(i=0;i<n;i++){
		scanf("%d",&pre[i]);
		in[i]=pre[i];
		cou[pre[i]]++;//cou[i]为0表示i不存在 
	}
	sort(in,in+n);//二叉搜索树中序必升序 
	node T=0;
	T=build(0,n-1,0,n-1);
	for(i=0;i<m;i++){
		flag1=flag2=1;
		scanf("%d %d",&c1,&c2);
		int c11=c1;
		int c22=c2;
		if(c1<0||cou[c1]==0){
			flag1=0;
		}
		if(c2<0||cou[c2]==0){
			flag2=0;
		}
		if(flag1==0&&flag2==0){
			printf("ERROR: %d and %d are not found.\n",c1,c2);continue;
		}
		else if(flag1==0){
			printf("ERROR: %d is not found.\n",c1);continue;
		}
		else if(flag2==0){
			printf("ERROR: %d is not found.\n",c2);continue;
		}
		if(c1>c2){//保持c1小,c2大 
			tmp=c1;
			c1=c2;
			c2=tmp;
		}
		dfs(T);
		if(ans==c11){
			printf("%d is an ancestor of %d.\n",ans,c22);
		}
		else if(ans==c22){
			printf("%d is an ancestor of %d.\n",ans,c11);
		}
		else{
			printf("LCA of %d and %d is %d.\n",c11,c22,ans);
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值