codeforces :Inversion Graph(c++)

这篇文章描述了一种根据给定的排列构建无向图的方法,并要求计算图中的连通组件数量。输入包含排列的长度和元素,输出是连通组件的计数。题目提供了样例输入和输出,以及一个简单的C++代码框架来解决这个问题。
摘要由CSDN通过智能技术生成

题目描述

You are given a permutation �1,�2,…,��p1​,p2​,…,pn​ . Then, an undirected graph is constructed in the following way: add an edge between vertices �i , �j such that �<�i<j if and only if ��>��pi​>pj​ . Your task is to count the number of connected components in this graph.

Two vertices �u and �v belong to the same connected component if and only if there is at least one path along edges connecting �u and �v .

A permutation is an array consisting of �n distinct integers from 11 to �n in arbitrary order. For example, [2,3,1,5,4][2,3,1,5,4] is a permutation, but [1,2,2][1,2,2] is not a permutation ( 22 appears twice in the array) and [1,3,4][1,3,4] is also not a permutation ( �=3n=3 but there is 44 in the array).

输入格式

Each test contains multiple test cases. The first line contains a single integer �t ( 1≤�≤1051≤t≤105 ) — the number of test cases. Description of the test cases follows.

The first line of each test case contains a single integer �n ( 1≤�≤1051≤n≤105 ) — the length of the permutation.

The second line of each test case contains �n integers �1,�2,…,��p1​,p2​,…,pn​ ( 1≤��≤�1≤pi​≤n ) — the elements of the permutation.

It is guaranteed that the sum of �n over all test cases does not exceed 2⋅1052⋅105 .

输出格式

For each test case, print one integer �k — the number of connected components.

题意翻译

现在有一个序列 �1,�2,…,��p1​,p2​,…,pn​,你需要构建一个无向图,规则是:当 �<�i<j 且 ��>��pi​>pj​ 时在 �i 和 �j 之间连一条无向边。问最后图中会有几个连通块。

Translate by CmsMartin

输入输出样例

输入 #1复制

6
3
1 2 3
5
2 1 4 3 5
6
6 1 4 2 5 3
1
1
6
3 2 1 6 5 4
5
3 1 5 2 4

输出 #1复制

3
3
1
1
2
1

说明/提示

Each separate test case is depicted in the image below. The colored squares represent the elements of the permutation. For one permutation, each color represents some connected component. The number of distinct colors is the answer.

代码:

#include<bits/stdc++.h>
using namespace std;
int t,n,p;
int main(){
    cin>>t;
    while(t--){
        int maxn=0,cnt=0;
        cin>>n;
        for(int i=1;i<=n;i++){
            cin>>p;
            maxn=max(maxn,p);
            if(maxn==i)cnt++;
        }
        printf("%d\n",cnt);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值