HDU 2717- Catch That Cow

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16596    Accepted Submission(s): 4949


题目链接:点击打开链接



Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input
5 17
 


Sample Output
4


Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


题意:
有个人一头牛在 k 点,而他在 n 点,这个人和他的牛在同一个直线坐标轴上,先在这个人想找到他的牛,他有两种方式:
第一种方式是行走:他可以在一分钟内从任意点 X 移动到点 X - 1 或 X + 1 
第二种方式是传送:他可以在一分钟内从任意点 X 被传送到点 2×X 。

现在给出 n 和 k ,让你计算他需要多少分钟才能抓到牛。(注意本题是多组数据测试)


分析:
用 bfs ,罗列出每一种状态存入队列开始搜索。


#include <iostream>
#include<string>
#include<string.h>
#include<stdio.h>
#include<queue>
using namespace std;

int n,k;
const int MAX= 100005;
const int N=100000;
int vis[MAX];

struct book{
int x,time;
};

int judge(int a)///判断是否出坐标出数轴的长度以及该点是否走过
{
    if(a>=0&&a<=100000&&!vis[a])
        return 1;
    return 0;
}

void bfs()
{
    queue<book>q;
    book pre,next;
    memset(vis,0,sizeof(vis));
    ///vis数组将走过的位置都标记起来,防止重复走
    pre.x=n;
    pre.time=0;
    vis[n]=1;
    q.push(pre);
    while(!q.empty())
    {
        pre=q.front();
        q.pop();
        if(pre.x==k)///如果该点是牛的位置,则说明找到了牛,输出所用的步数
        {
            printf("%d\n",pre.time);
            return ;
        }
        ///罗列三种状态
        next.x=pre.x+1;
        if(judge(next.x))
        {
            vis[next.x]=1;
            next.time=pre.time+1;
            q.push(next);
        }
        next.x=pre.x-1;
        if(judge(next.x))
        {
            vis[next.x]=1;
            next.time=pre.time+1;
            q.push(next);
        }
        next.x=2*pre.x;
        if(judge(next.x))
        {
            vis[next.x]=1;
            next.time=pre.time+1;
            q.push(next);
        }
    }
}

int main()
{
    while(~scanf("%d %d",&n,&k))
        bfs();
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值