Eming

先贴水题一道:

Eming

   

   Eming is a contest hold by WHUACM trainingteam. The aim is to select new members of the team.

   Usually, the first problem is a very simpleproblem such as “a+b problem”. But this time, Xioumu is tired of this kind of problem,he decide to solve “a and b problem”.

   Give you the result of a + b and a^2 – b^2,please output the result of a and b.

 

   Input

   There are several test cases. For each casethere are two double numbers indicating a+b and a^2-b^2. You may assume that a+bwill not be zero.

 

   Output

   For each case please output the result of aand b in one line, rounded to 2 decimal places.

 

   SampleInput

   3 -3

 

   SampleOutput

   1.00 2.00



刚开始写博客,写的不好见谅。

这个题第一眼看到a+b和a^2-b^2,果断应该想到a^2-b^2能看做(a+b)(a-b)。这样就能知道a-b。同时知道a+b和a-b求a和b就不用说了。

题目代码:

#include<iostream>
using namespace std;
int main()
{
    double a,b,aa,bb,c;
    while(cin>>a>>b)
    {
        c=b/a;
        aa=(a+c)/2;
        bb=a-aa;
        cout.setf(ios::fixed);
        cout.precision(2);
        cout<<aa<<" "<<bb<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值